Solaris/Panorama wm: ALT accl. don't work, enter ALTed key

NEW
Unassigned

Status

()

Core
Keyboard: Navigation
P3
normal
18 years ago
5 years ago

People

(Reporter: David M. Karr, Unassigned)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
Sun
Solaris
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; SunOS 5.5.1 sun4u)
BuildID:    2000061821

I press ALT-n to create a new window.  It doesn't create
a new window, but just enters "n" in the URL field.  All accelerators are
behaving the same way.
Note that I am not using CDE as my window manager, but
Panorama (formerly sold by SCO).  I hope that is not the
issue.

Reproducible: Always
Steps to Reproduce:
1. Bring up mozilla.
2. Put focus in URL field.
3. Hold down ALT.
4. Press "n".

Actual Results:  The letter "n" appears in the URL field.

Expected Results:  A new Mozilla window should have been created.

My platform is using the Panorama window manager, not CDE.
I'm also executing Mozilla on a 2.6 system, but displaying on a 2.5.1 system.

Comment 1

18 years ago
Works for me on Linux 061908 build, can you try today's build on your system?
Also, if you click on the regular page part of the Moz window, does alt+n work?

Comment 2

18 years ago
we need to find a solaris user for this.

Comment 3

18 years ago
yes, we need someone with solaris to test this....
Assignee: asa → don
Component: Browser-General → Keyboard Navigation
Keywords: qawanted
QA Contact: doronr → szhu
(Reporter)

Comment 4

18 years ago
With build 2000061921, with the focus in the URL field, it still just
inserts an "n" into the URL field, but doesn't create a new window.

If I manually put the focus into the main page area, pressing ALT-n
does nothing.

Comment 5

18 years ago
i tried it on solaris 2.7 using build 2000042619. Alt-n works for me.

Comment 6

18 years ago
Sander, can you please try again on a 6/21 nightly build?
(Reporter)

Comment 7

18 years ago
Tried again on 6/21 build.  No change.

However, I also tried the same test, running it on the same workstation, but
displaying on a workstation using CDE, instead of Panorama.  As I feared, that
test case does not fail.  It correctly brings up the new window, and doesn't
insert "n" into the URL field.

Oddly enough, this scenario is similar to an issue I discovered quite a while
ago with running Java applications on Solaris, and displaying on either CDE or
Panorama.  If I display them in Panorama, then accelerators have no effect.  I
don't remember whether the un-ALTed key would pass through to focused
textfields.  If I ran the same application, displaying in CDE, then accelerators
work fine.

Note that accelerators in other applications, like Netscape 4.7x, work fine,
whether displaying in Panorama or CDE.

I don't know, and I seriously wonder, whether this same symptom will occur while
displaying in fvwm or KDE, on Solaris.

Comment 8

18 years ago
*spam* changing all open or resolved bugs that szhu@netscape.com was the QA 
contact for to sairuh@netscape.com.  szhu is no longer with netscape, and these 
bugs could lie dormant otherwise.  sorry for spam.
QA Contact: szhu → sairuh

Comment 9

18 years ago
Tested on Solaris2.6 with build 2000062921. Alt-n works fine.
Note that my display actually is on a Linux machine where I use fvwm95-2.

Comment 10

18 years ago
This looks like a modifier problem. Can you post output of 'xmodmap' command if
you are having problems.

It's best to have Mod1 modifier set to the key you wish to use as Alt.

Comment 11

18 years ago
mcafee, m21
resummarized
Assignee: don → mcafee
Summary: ALT accelerators don't work, enter ALTed key → Solaris/Panorama wm: ALT accl. don't work, enter ALTed key
Target Milestone: --- → M21

Comment 12

18 years ago
Marking as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

18 years ago
some gtk acclerator fixes havebeen/are going into the tree,
can you try this again?

Comment 14

17 years ago
I tried this on Solaris 2.8 platform using nightly build moz: 2001041710 and see
that pressing alt+n keys does not start a new browser.

Not sure if this is supposed to work on windows platform. When I tried it on win
NT 4.0 with nightly build : 2001041704 I saw the problem as well. ie., a new
navigator window was not started when alt+n keys were pressed.

Comment 15

17 years ago
i'm confused, do you have a pref set to use alt as your modifier? if not then 
ctrl-n from chrome/content (but not edit boxes) should open a new window

Comment 16

17 years ago
ok, thanks, ctrl+n works both on solaris and windows nightlies, as I do not have
my prefs set to alt+n..

Comment 17

17 years ago
nobody
Assignee: mcafee → nobody
Keywords: helpwanted

Updated

16 years ago
Blocks: 163789
QA Contact: bugzilla → keyboard.navigation

Comment 18

5 years ago
Can anyone with Solaris please test and see if this bug still reproduces?
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.