Multiple address book support for Junk settings

RESOLVED DUPLICATE of bug 187771

Status

Thunderbird
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 187771
10 years ago
10 years ago

People

(Reporter: Vince LaMonica, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: version 2.0.0.12 (20080213)

This is a feature request. I would like to be able to select more than one address book in the Junk settings to 'whitelist' incoming e.mail. Currently the setting labeled, "Do not mark mail as junk if the sender is in:" provides a dropdown menu with a list of one's address books. I would like to request that it be a list that one could select multiple address books with. I have two situations where this may be useful:

If one uses their Personal Address Book to put in new addresses and uses their Collected Addresses to have Thunderbird automatically insert addresses they have sent mail to, it would make sense that addresses in both address books should be whitelisted. Currently this is not the case.

The other situation comes up when one is using an LDAP address book for their company and each Thunderbird install also has the user's Personal Address Book; I do not know if it is possible to cache the LDAP address book, but if so, then being able to white list both of these address books [as well as the Collected Addresses] could be very helpful.

A current workaround is to simply force the user to use their Personal Address Book for both creating new addresses as well as having Thunderbird collect sent mail's addresses into. But to me, this seems like a disorganized way to go, and doesn't address the LDAP address book issue.

Reproducible: Always

Steps to Reproduce:
1.Select Tools->Account Settings->Junk Settings
2.Check mark "Do not mark mail as junk if sender is in:"
3.Note that one has a drop down menu and can only select one address book
Actual Results:  
It works as advertised; this is a feature request to allow one to choose more than one address book in that setting.

Expected Results:  
I would like to see a list that one could command-click/control-click on to select multiple address books for inclusion into Thunderbird's "whitelist"
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0
Not being able to do multiple address books for Junk is bug 187771 that has already been fixed for the next release.

LDAP Junk mail would be bug 180012
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187771
You need to log in before you can comment on or make changes to this bug.