Open Bug 430469 Opened 14 years ago Updated 8 months ago

Breakpad can't send crash report if proxy authentication is needed

Categories

(Toolkit :: Crash Reporting, defect)

x86
All
defect
Not set
normal

Tracking

()

People

(Reporter: yoshimit, Unassigned)

References

Details

(Whiteboard: [notacrash])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When Breakpad comes up with a new crash report to send, there's no dialog asking for username/password to my proxy, therefore the report can't be sent.

Sorry if this is a dup. I couldn't find it.

Thank you.

Reproducible: Always

Steps to Reproduce:
1. Make sure you are under a proxy authentication required lan
2. Make Firefox 3 crash
3. Try send the crash report
Actual Results:  
Failure to send the crash report because Squid can't authenticate the user.

Expected Results:  
The dialog asking username/password should appear (as do when extensions tries to find updates)
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 385280
bug 385280 covers windows too ?
After talking to Ted Mielczarek, I'm asking to reopen this bug for further investigation.

Bug 385280 is Linux only and don't cover proxy authentication (this bug).
Bug 405932 dont handle authentication too.

Thank you.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Component: General → Breakpad Integration
Product: Firefox → Toolkit
Version: unspecified → Trunk
QA Contact: general → breakpad.integration
Duplicate of this bug: 464429
Confirming that I have this bug as well, running the latest Minefield (11/17/2008) on Windows XP.  This is a long-standing bug that should get some prompt attention; it is probably cutting off many crash reports from corporate environments.

I have the proxy set correctly in IE, but get no prompt in Crash Reporter, just a silent fail.  It does not matter if I have an IE window open and connected through the proxy.
we currently have way more crash reports than we need (and are periodically looking for ways to limit the number of reports we process). if you want to do something w/ specific crashes you can either use https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg to trap future crashes or use windbg to open the existing .dmp files.

If you think your crashes are terribly important you can try to host them for someone (probably me). however we're all very busy and have way more crash reports than we need, so unless you have some really good reason to believe your crash isn't already covered by an existing bug (w/ stack trace) or report in our crash database, then you're just wasting someone's time and you should try to arrange to fund someone (that can't really be me, my employer would object).
"we currently have way more crash reports than we need..."

If that's truly the case, perhaps you should take this off the Start
page:

> Please use the Crash Reporter and turn it on when it asks. The Crash
> Reporter reports give us really valuable data on which crashes are
> the most serious, and how often people are encountering them.

Why are you telling people that it is *really* important to use the
Crash Reporter when (1) you know it doesn't work, and (2) you're busy
ignoring the data you get?
It does work just fine for the vast majority of people, and we're studying data in the aggregate, so while each individual report is not enormously valuable, having a statistically large enough sample of them is useful. I'm sorry it doesn't work for you. We have bugs, and we don't have enough time to fix them all. We think that we're currently getting enough crash reports to make this not a critical bug.
same problem on Linux (Ubuntu 7.10) using 3.1b2.
I am aware that this might not be critical, but setting it to "NEW" nevertheless, as it certainly exists.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Same problem on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 ImageShackToolbar/5.2.1

I also use it to get to internet from inside a corporate network that requires proxy authentication.

If this happens also to me, could be that the crash-report system is not getting ANY "possible/potential" bugs which are only observable when people uses automatic proxy servers.

From my point of view, it is a bug which is impeding to get more probable bugs being reported!!!

Should be addresed.

Firefox has already more functionality that it already needs, what is lacking is more robustness. 

Cheers,

Jm
Same problem on: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

You may claim you have more reports than you need, but you are talking about a living application, not some piece of software that is released once and is never improved upon.  I have had 3.5 crash more times on one day than I have experienced in the last several years.  What you need is better data mining, not fewer reports.  Limiting reports only masks the importance of a bug.  If you limit automatic reporting, you're only going to see more and more people on bugzilla cluttering up the place with duplicates.
Duplicate of this bug: 36545
I believe that this bug is somewhat mitigated by bug 378528 which allows the application to resubmit pending reports (if it supports about:crashes)
Could it be that this is now fixed with 3.6.4? I just had a crash and I think it was properly submitted. Marking as resolved/WFM, please undo if needed.
Status: NEW → RESOLVED
Closed: 14 years ago11 years ago
Resolution: --- → WORKSFORME
No, we didn't change anything. Did you experience a plugin crash? We send those from within the browser process, so it should work there.

This bug is about the crash reporter client that appears when the entire app crashes.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
It was indeed a plugin crash which I think caused the whole browser to close (crash?). It seemed to me that the report was successfully submitted. Well, at least, I didn't get a message telling me that it could not do it. If I understand properly, it could be that I submitted it myself, after the fact, by clicking on the ID in about:crashes. This is not really obvious to me. Will crashes be submitted automatically when the browser is active (and therefore bypass the proxy authentication issue)?

The about:crashes window is called "Submitted Crash Reports" but it seems it does the submission when clicking on the IDs and then prefixes them with bp-.
Crashes are not automatically resubmitted. Yes, you can submit crash reports that failed to submit simply by clicking on them in about:crashes. The UI around that is not very clear, but we hope that it works seamlessly (which it seems to have in your case).
Status: REOPENED → NEW
Whiteboard: [notacrash]
You need to log in before you can comment on or make changes to this bug.