If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Actions in sub-menus should be editable

RESOLVED FIXED

Status

Mozilla Labs
Operator
--
enhancement
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Sven, Assigned: mkaply)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 0.9.1

The behavior Operator displays is that I can change actions available in the main menu; for example when I right-click the Operator icon. Whatever actions are set in the options will be available in this right-click menu.

However, the options apparently don't influence the actions available in the sub-menus. When I enable data formats display style each item for a microformat has _all_ possible actions listed. It doesn't matter if I for example don't use del.icio.us and ma.gnolia - I always get the options to look for bookmarks on these sites.

I'd like an option to also change available actions for the sub-menus if I have data formats display style enabled.

Reproducible: Always

Steps to Reproduce:
1. Enter Operator options
2. Make sure data formats display style is enabled
3. Change available actions, e.g. delete all but one action
4. Close Operator options
5. Browse to a page that provides Operator-readable data
>> E.g. http://www.kaply.com/weblog/operator/
6. Right-click an Operator icon
7. Find all actions available in the sub-menu instead of just the ones that you've enabled in the options
Actual Results:  
Operator lists all possible actions for each data format

Expected Results:  
Operator lists only actions that are enabled in the options menu
(Reporter)

Comment 1

10 years ago
Created attachment 317314 [details]
Screenshot showing Operator sub-menu with all possible actions instead of just the ones enabled in the options

A screenshot that shows an Operator sub-menu with all possible actions listed instead of just the ones that are enabled in the options menu.
(Assignee)

Comment 2

10 years ago
Actually that's not what customizing the actions is about.

Customizing actions is about setting the default actions when you switch to "Actions" mode in operator.

But you bring up an interesting question. Is there a way to turn off actions you don't want to see on the submenus.
(Reporter)

Comment 3

10 years ago
Ah alright, I wasn't aware that that's intended. Then this is a plain request instead of a request combined with a report about strange behavior.

I'd like to be able to turn off actions I don't need.
(Assignee)

Comment 4

8 years ago
I think I am going to get rid of Actions mode completely and use that action list to define what actions appear
(Assignee)

Comment 5

8 years ago
This is in the latest Operator
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.