If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tinderbox should pull the tree by date

RESOLVED FIXED

Status

SeaMonkey
Build Config
P3
enhancement
RESOLVED FIXED
19 years ago
13 years ago

People

(Reporter: Steve Lamm, Assigned: use leaf@mozilla.org)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The "C" (i.e. changes) links, on tinderbox are pretty meaningless because they
may or may not represent what the tree actually pulled. If tinderbox pulled by
date, then the "C" links could be accurate. This is assuming that files don't
show up later because of the mirroring delay.

The date should be at least as early as when the build began. (Perhaps 5 minutes
earlier to factor in the mirroring delay). In other words, if a tree start to
build at 10:32, then it should pull with a date of 10:32 (and maybe 10:27).

Updated

19 years ago
Assignee: cyeh → briano

Comment 1

19 years ago
Assigning to briano.

Brian, please change the UNIX tinderbox script to do this. When it's checked in,
assign it back to me so we can get Win and Mac to do the same thing.

Updated

19 years ago
Assignee: briano → cyeh

Comment 2

19 years ago
Done for mozilla/tools/tinderbox/build-moz-smoke.pl (I really think
we should make this work on non-Unix platforms as well...).  The
default is to build with a timestamp, but there is a flag to turn
this off.  One thing I don't like about using a timestamp is the
extra time required for each checkout.  I don't know how significant
it'll be for an entire Tinderbox build pass, but it _will_ be
noticeable.  Fortunately, there should be only one or two time
comparisons per ,v file at most.  We'll see.

Updated

19 years ago
Assignee: cyeh → sar

Comment 3

19 years ago
sar to hold meeting about tinderbox improvements.
(Reporter)

Updated

19 years ago
Assignee: sar → cyeh
(Reporter)

Comment 4

19 years ago
sar is gone. Assigning back to cyeh.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Target Milestone: M7

Comment 5

19 years ago
this is a low priority, setting m7
(Reporter)

Comment 6

19 years ago
Without this fix, the "Guilty" column will continue to be out of sync with the
builds. And the "C" changes links are meaningless. Maybe I should take the links
off tinderbox.

Updated

19 years ago
Target Milestone: M7

Updated

19 years ago
Severity: normal → enhancement

Comment 7

19 years ago
marking as enhancment, probably won't be looked at any time soon.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
*** This bug has been marked as a duplicate of 12660 ***

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 9

18 years ago
I can't see anything about this bug that is related to bug 12660.  12660 is
an HTML Form Controls bug.

Updated

18 years ago
Resolution: DUPLICATE → ---

Comment 10

18 years ago
Clearing DUPLICATE resolution due to reopen.

Comment 11

18 years ago
mass reassign to leaf
Assignee: cyeh → leaf
Status: REOPENED → NEW

Comment 12

18 years ago
I thought this was fixed. i'll double check.
Status: NEW → ASSIGNED

Comment 13

18 years ago
this is, in fact, fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.