Rename new search "New Query" default name to "New Search"

VERIFIED FIXED in Firefox 3.5

Status

()

Firefox
Bookmarks & History
P3
normal
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: Andrés Delfino, Assigned: dietrich)

Tracking

Trunk
Firefox 3.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008042311 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008042311 Minefield/3.0pre

We should hide technical and unfamiliar names to end users.

Reproducible: Always

Steps to Reproduce:
1. Go to Library.
2. Do a search.
3. Click Save.
Actual Results:  
A dialog appears with the default name "New Query" for the new search.

Expected Results:  
The dialog should have the default name "New Search" for the new search.
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk

Comment 1

10 years ago
To clarify: The default value for Name is "New Query"  which should be changed to "New Search" to be consistent with the use of "Search" through out this process.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> To clarify: The default value for Name is "New Query"  which should be changed
> to "New Search" to be consistent with the use of "Search" through out this
> process.

Exactly.
yep, totally agree that we shouldn't say New Query.  Perhaps "New Search Folder?" We also need to get that added to the organize menu at some point.  Probably too late due to the l10n freeze unless we already have the strings.

Comment 4

10 years ago
I'd recommend skipping the "Folder". Conflating the ideas of a list of search results and a hierarchical folder you drag'n'drop stuff into is just sacrificing clarity and courting confusion. IMHO. Maybe I'm pedantic.

"New Search" alone feels kind of verb-ish. I'd click on it to start a search.

How about "New Search Results"?
(Assignee)

Comment 5

10 years ago
This was changed to "Save Search" a while back -> WFM.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> This was changed to "Save Search" a while back -> WFM.
> 

Still says "New Query" to me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052114 Minefield/3.0pre
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 7

10 years ago
Yes sir, you are correct! I was looking at the title label.
(Assignee)

Comment 8

10 years ago
Created attachment 322028 [details] [diff] [review]
fix
Assignee: nobody → dietrich
Status: REOPENED → ASSIGNED
Attachment #322028 - Flags: review?(mano)
Comment on attachment 322028 [details] [diff] [review]
fix

The entity name should be changed.
Attachment #322028 - Flags: review?(mano) → review-
(Assignee)

Comment 10

10 years ago
Created attachment 322040 [details] [diff] [review]
fix

er, sorry, i'm new here.
Attachment #322028 - Attachment is obsolete: true
Attachment #322040 - Flags: review?(mano)
Comment on attachment 322040 [details] [diff] [review]
fix

Indeed you are, where's the usage (xul/js) update?
Attachment #322040 - Flags: review?(mano) → review-
(Assignee)

Comment 12

10 years ago
Created attachment 322153 [details] [diff] [review]
omg
Attachment #322040 - Attachment is obsolete: true
Attachment #322153 - Flags: review?(mano)
Comment on attachment 322153 [details] [diff] [review]
omg

r=mano
Attachment #322153 - Flags: review?(mano) → review+
(Assignee)

Updated

10 years ago
Duplicate of this bug: 420598
(Assignee)

Comment 15

10 years ago
fixed in mozilla-central (f8640caa2858)
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago10 years ago
Priority: -- → P3
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
Target Milestone: Firefox 3.1 → Firefox 3.5
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.