Closed Bug 430583 Opened 12 years ago Closed 12 years ago

Smart Bookmarks "most visited" list has duplicate entries.

Categories

(Firefox :: Bookmarks & History, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 420446

People

(Reporter: mjkeeler7, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

The smart bookmarks folder has an item called most visited.  I assume this is a list of the web pages you view most often and that their should not be duplicates. However, it shows multiple entries for iGoogle and Google Code.  

Reproducible: Always

Steps to Reproduce:
1.Not really sure, it doesnt seem like somethings happening, only that something is not stored properly or something like that.
2.
3.



Expected Results:  
One entry in the list for iGoogle and one for Google Code.  They should not be duplicated.
Depends on: 430614
No longer depends on: 430614
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
Can you click on the duplicates and confirm that URL is the same for both? Some sites append unique identifiers in the URL that change per visit.
I have a similar (probably identical) on Windows in 3.0RC1.

Of the ten slots in the most visited menu six are taken up by two sites. The URLs are different but end up being the same page.

One of the pages is GMail inbox which is duplicated as:
http://mail.google.com/mail/
https://mail.google.com/mail/ 
https://mail.google.com/mail/#inbox

The other is a TeamTrack bug tracking site 
https://<internal host>/tmtrack/tmtrack.dll
https://<internal host>/tmtrack/tmtrack.dll?
https://<internal host>/tmtrack/tmtrack.dll?LoginPage (this is a different page admittedly but is ultimately uninteresting)

It would difficult to find a set of heuristics to filter these out but it would be nice to at least be able to manually mark a url to be ignored for the purpose of most visited.
this is the same as bug 420446
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 420446
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.