Closed Bug 430597 Opened 12 years ago Closed 12 years ago

New clearListButton does not accommodate larger fonts

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla1.9

People

(Reporter: ehume, Assigned: Mardak)

References

Details

(Whiteboard: [has fix in bug 430486])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042305 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042305 Minefield/3.0pre

The new addition to downloads.css is

#clearListButton {
  min-height: 0;
  min-width: 0;
  height: 1em;
}

Unfortunately, when a somewhat larger-than-microscopic font is used, this produces a button that is not large enough to accommodate the text. See first attachment.

When this code is omitted from downloads.css (at least in my theme), the button displays normally. See second attachment.

Reproducible: Always




Process failure: lack of routine testing of browser elements against larger
font sizes. Since the testing is not done routinely, this kind of bug appears
routinely.
Just remove the 'height:1em' completely...
Right. We themers can remove that code. But what about users who have their systems set to larger fonts. The default theme looks amateurish.

Please confirm this so we can get the devs' attention.
Duplicate of this bug: 430647
Assignee: nobody → edilee
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [has fix in bug 430486]
Version: unspecified → Trunk
Depends on: 430486
http://hg.mozilla.org/cvs-trunk-mirror/index.cgi/rev/e8f7ad982adf#l5.7
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
-> v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.