Caption of "Clear List" button is misaligned with Meiryo font

VERIFIED DUPLICATE of bug 430597

Status

()

Toolkit
Downloads API
--
trivial
VERIFIED DUPLICATE of bug 430597
10 years ago
10 years ago

People

(Reporter: Atsushi Sakai, Assigned: Mardak)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has fix in bug 430486])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja-JP-mac; rv:1.9pre) Gecko/2008042418 Minefield/3.0pre Firefox/3.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2007042305 Minefield/3.0pre 

The height of "Clear List" button is 1em.
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/themes/winstripe/mozapps/downloads/downloads.css&rev=1.32&mark=80#77

But the default line-height of Meiryo font is approximately 1.5em.
So, 1em is too narrow.

This should be fixed because Meiryo is Windows Vista Japanese's default font, so many Japanese users uses Meiryo.

Reproducible: Always

Steps to Reproduce:
1. Change OS Theme to use Meiryo if Meiryo is not used.
   This may not be required on Windows Vista Japanese because this is default.
2. Open Download Manager.

Actual Results:  
Caption of "Clear List" button is misaligned.

Expected Results:  
Caption of "Clear List" button is aligned correctly.
(Reporter)

Comment 1

10 years ago
Created attachment 317522 [details]
screenshot
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Created an attachment (id=317522) [details]
> screenshot

The caption in this screenshot is "Clear List(C)", not "Clear List".
But this is not related to this bug, sorry if cofusing.

I mean, the caption is too low.
Why the height is needed? It seems that that should be removed.
Blocks: 400495
(Assignee)

Updated

10 years ago
Depends on: 430486
(Assignee)

Updated

10 years ago
Assignee: nobody → edilee
Whiteboard: [has fix in bug 430486]
duplicate by Bug 30597?
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 430597
Verified dup
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.