elsa: can't include <map> with gcc 4.3

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
10 months ago

People

(Reporter: benjamin, Assigned: dmandelin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Using gcc 4.3 (haven't tested gcc 4.2, this is not a problem with gcc 4.1.2)

testcase is

#include <map>

Preprocessed and then run through `ccparse -tr permissive` this fails with

Assertion failed: value.hasValue(), file mtype.cc line 1556
Failure probably related to code near /builds/gcc-mcpp/installed/include/c++/4.3.0/bits/stl_tree.h:424:29

Which is the following code:

_Rb_tree_impl<_Compare> _M_impl;

And the declaration of _Rb_tree_impl is:

template<typename _Key_compare,
         bool _Is_pod_comparataor = __is_pod(_Key_compare)>
  struct _Rb_tree_impl : public _Node_allocator
  { ... }

So this is very likely caused by the __is_pod builtin being used as a default template value.

This is not urgent: I'm just going to downgrade my pork tree to use gcc 4.1.x which doesn't have the problem.
At this time, Mozilla is no longer pursuing the use of Elsa and Pork for static analysis and rewriting. Therefore, there are no longer any intentions to fix or support any outstanding bugs in these tools.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.