Closed Bug 430661 Opened 12 years ago Closed 12 years ago

Multi-column sorting not achievable because sorts are not "stable sorts".

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 57898

People

(Reporter: bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: version 2.0.0.12 (20080213)

I expect that when a sort on a key (e.g., Sender) has multiple entries for some value of the key (i.e., some particular Sender appears multiple times) then the order of messages with that value will be determined by the order they were in previous to my requesting the sort.  For instance, if I sort by Attachment then all attachments appear first.  If I then sort by Sender, I expect that for each Sender, the messages that have attachments will appear before the messages without attachments.  I have seen this called "stable sorting."

Having stable sorting allows me to do sorting on multiple columns.  I simply sort one-by-one on each column starting with the least significant and finishing with the most significant.

This happens in the unthreaded view.

Reproducible: Always

Steps to Reproduce:
1. In unthreaded view, sort by Attachment.  
2. Sort by Sender.  
3.
Actual Results:  
After step 1. Observe that messages with attachments appear before those without attachments.

After step 2. Observe that messages from a given sender are grouped together, but those with attachments do not necessarily precede those without attachments.

Expected Results:  
I expect that, after the second step, messages from a given sender will be grouped together, and those messages with attachments will precede those messages without attachments.
Dup of Bug 57898, which was opened at end of 20-th century?
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 57898
You need to log in before you can comment on or make changes to this bug.