Wacko error message "(void 0) is undefined;'

RESOLVED DUPLICATE of bug 420919

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 420919
10 years ago
10 years ago

People

(Reporter: John J. Barton, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I get the subject error message on the line

        if (!this.scriptsByJSContextTag[tag])

in http://fireclipse.svn.sourceforge.net/svnroot/fireclipse/trunk/FireclipseExtensions/chromebug/content/ChromeBug/ChromeBugPanel.js

Something must have landed in the last couple of nightly builds that is messed up.
Do you have a regression range at all?  It sounds like something that would be fall-out from a much, much older patch than that, so I'm curious.
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 2

10 years ago
I just tried 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042207 Minefield/3.0pre
which should have been the version I used to 4/23 and the message appears, to my surprise.
(Reporter)

Comment 3

10 years ago
Maybe another line will help:

        var tag = frame.executionContext.tag;

        if (!this.scriptsByJSContextTag[tag])

where frame is from jsd during onBreakpoint handling for a browser-generated event script where the breakpoint is on PC=0. 

I'll try further back.
(Reporter)

Comment 4

10 years ago
Same message from
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042006 Minefield/3.0pre
so something on my end changed to start it.
Looks like a duplicate of bug 420919, but that's been around longer than the "last couple of nightly builds".
Oh, didn't see your last comment.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 420919
(Reporter)

Comment 7

10 years ago
Yep, this.scriptsByJSContextTag was undefined, due to some 'improvement' on my end.
You need to log in before you can comment on or make changes to this bug.