directory listing file:// generates "Page Load Error"

RESOLVED DUPLICATE of bug 426776

Status

()

Core
Networking: File
RESOLVED DUPLICATE of bug 426776
10 years ago
9 years ago

People

(Reporter: juergen smann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080206 Camino/1.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080206 Camino/1.5.5

dear mozilla people,

some directories on my iMac end up with "Page Load Error"
e.g: file:///Users/otto/JRS/Me

while other (sub)directories are displayed as desired:
file:///Users/otto/JRS/Me/OldStuff
file:///Users/otto/JRS/Dance
only certain directories are affected, and others not. 
I have no clue, what makes the difference between the good dir's and the bad ones.

this erronious behavior is true for firefox as well.

thanks, juergen.

Reproducible: Always

Steps to Reproduce:
1.enter  file:///Users/otto/JRS/Me  as URL in camino or firefox.
2.
3.
Actual Results:  
displays error window "Page Load Error"

Expected Results:  
display the directory listing

Comment 1

10 years ago
Do these directories display properly in Safari?

If they do, this could be either a) a bug in Core:File handling or b) an intentional behaviour of Gecko for a reason that's not yet clear.

If they don't, it's likely this is INVALID and either a) a bug in the OS or b) intentional OS behaviour, again for a reason that's not yet clear.

It might be instructive to do a "ls -salt" inside the /Users/otto/JRS/ directory from within Terminal.app and see what the differences are between the directories that display properly and those that don't.

cl
(Reporter)

Comment 2

10 years ago
safari has no problem with all my directories, as it switches
to the finder application.

"ls -salt" does not show any differences to other directories.
0 drwxr-xr-x    7 jrs  jrs      238 Nov  4 21:49 Html
0 drwxr-xr-x    5 jrs  jrs      170 Mar 19 09:55 Mac
0 drwxr-xr-x   47 jrs  jrs     1598 Apr 28 10:09 Me
0 drwxr-xr-x   29 jrs  jrs      986 Apr 18 19:55 Phto
regarding the file history, the directory is imprted via tar
from SunOS. howevr, the file .DS_Store does exist.
could that be of some importance?

thanks for helping, juergen.

Comment 3

10 years ago
So the *affected* directories were imported via tar from SunOS? And contain a .DS_Store file? Please be a little more specific ;)

Specifically what "page load error" are you getting? Can you put up a screen shot, using the "add an attachment" link?

cl
(Reporter)

Comment 4

10 years ago
Created attachment 318600 [details]
error camino
(Reporter)

Comment 5

10 years ago
Created attachment 318601 [details]
error FF screenshot
(Reporter)

Comment 6

10 years ago
(In reply to comment #3)
1. I mentioned the .DS_Store file, since I felt that this indicates, 
that OSX has "accepted" the SUN tar files and directories. other way 
around: if OSX would not have created these files, it might indicate a 
non "acceptance" of the tar files. I belive, this is not so important.

2. the error messages I get:
2a. Camino banner: "Problem loading page"
Camino content:
"File Not Found   
 The file /Users/jrs/JRS/Me cannot be found. Please check the location and 
 try again.

    * Could the item have been renamed, removed, or relocated?
    * Is there a spelling, capitalization, or other typographical error 
      in the address?
    * Do you have sufficient access permissions to the requested item?"
[and then a click box:] "Try Again"


2b. FF banner: "Problem loading page"
FF content:
"File not found
 Firefox can't find the file at /Users/jrs/JRS/Me.
    *   Check the file name for capitalization or other typing errors.
    *   Check to see if the file was moved, renamed or deleted."
[and then a click box:] "Try Again"

3. the 2 screenshots are attatched

again, thanks for helping, juergen.

Comment 7

10 years ago
Perhaps bug 426776, or something of a similar nature. Check inside the directories that won't display for unusual files of any kind (broken links, odd ownership/permission, etc.)

Whatever the issue, it's clearly not Camino-specific, so moving to the right component.
Component: General → Networking: File
Product: Camino → Core
QA Contact: general → networking.file
(Reporter)

Comment 8

9 years ago
it's very likely, that bug 426776 will solve my problem,
since - due to the tar import - I had broken links in that directory,
and removing / resolving them lead to the expected display of 
the directory. 


thanks again, juergen.

Comment 9

9 years ago
duping. please reopen bug if your issue is not resolved when bug 426776 is fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426776
You need to log in before you can comment on or make changes to this bug.