With Camino 1.6 selected as default browser links from AIR application do not load

RESOLVED DUPLICATE of bug 403346

Status

RESOLVED DUPLICATE of bug 403346
11 years ago
10 years ago

People

(Reporter: mturro, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; en-us) AppleWebKit/525.13 (KHTML, like Gecko) Version/3.1 Safari/525.13
Build Identifier: Version 1.6 (1.8.1.14 2008040911)

Using Twhirl and AlertThingy - when clicking on links in the AIR app interface the link will load in Firefox and Safari when those browsers are set as the default.  If I switch to Camino the clicked link will go to the broswer but nothing happens.  Also- the AIR apps and the browsers are set to occupy different spaces in Leopard.

Reproducible: Always

Steps to Reproduce:
1.set camino and the AIR app (Twhirl) to occupy two different spaces in Leopard
2.set camino as default browser for the system
3.click links in AIR app


Actual Results:  
The desktop will switch to the correct browser space, but nothing will load or try to load in the browser

Expected Results:  
The desktop should switch to the browser space and load the appropriate link.
(Reporter)

Comment 1

11 years ago
FYI - I used Safari to fill out this form , but it is Camino that exhibits the problem.
Can you provide URLs where one can download these other apps?

In the future, please do use the version of Camino that exhibits the problem to fill out the bug report form when at all possible.  Thanks.
Component: General → OS Integration
QA Contact: general → os.integration

Comment 3

11 years ago
Is step 1 actually necessary? Spaces aren't something any apps have any control
over. Also, given how buggy Spaces behavior is when auto-switching, have you
verified that a new window isn't opening in a space other than the one switched
to?

In step 3, does it matter whether or not you already have windows open in
Camino? What is your setting in the Tabs preferences for "Links opened by other
applications"?
(Reporter)

Comment 4

11 years ago
URL for Twhirl download : http://twhirl.org/  

URL for Alert Thingy: http://www.alertthingy.com/

Also: These are AIR based apps so you will need AIR installed - http://get.adobe.com/air

On further investigation it appears that Step 1 is not necessary to reproduce.  With both the AIR apps and Camino 1.6 in the same space the same thing happens. 

The clicked link is not hiding - it is not opening in any space at all.  

When the link is clicked it will open Camino if it's closed... with the previous sessions loaded if "Load pages that were open before quitting" is checked and just the homepage if it's not.

Tabs preference for "Links opened by other
applications" has "open links in background" UN-checked.

Comment 5

11 years ago
Do links from other apps open correctly? If you don't have any convenient examples, you can just type http://apple.com in TextEdit, and right click in and choose "Make Link"

Comment 6

11 years ago
You haven't mentioned this yet, so...did this work in earlier Camino versions? If so, which one(s)?

We think this might be related to (or even a dupe of) bug 403346.

cl

Comment 7

10 years ago
Could you respond to comments 5 and 6 please?
(Reporter)

Comment 8

10 years ago
Links from other apps open correctly as do links from earlier versions of Camino - Camino 1.5 specifically.

Comment 9

10 years ago
Sounds like this is a dupe, then. To be sure, try this Camino build:

ftp://ftp.mozilla.org/pub/mozilla.org/camino/nightly/latest-1.6-M1.8/

which has the fix for bug 403346 incorporated into it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403346
(Reporter)

Comment 10

10 years ago
That's it... working with new build.  Thanks!
You need to log in before you can comment on or make changes to this bug.