###!!! ASSERTION: XPIManager: output stream doesn't exist: 'mItem->mOutStream'

VERIFIED DUPLICATE of bug 475526

Status

()

Core
General
VERIFIED DUPLICATE of bug 475526
10 years ago
9 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({assertion})

Trunk
x86
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 317730 [details]
stack

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042320 Firefox/3.0pre ID:2008042320

Steps to reproduce:
Was trying to download https://addons.mozilla.org/en-US/firefox/addon/1478 and got a Download Error.

Also this caused a Assertion:
 ###!!! ASSERTION: XPIManager: output stream doesn't exist: 'mItem->mOutStream', file /debug/mozilla/xpinstall/src/nsXPInstallManager.cpp, line 1156
Looking at it I'm not sure how useful that assertion is. It seems that if the download fails a https certificate check or is just not a 2xx http response then the download is cancelled before the output stream is created so it will assert.

Is this reproducable?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Is this reproducable?
> 


Yes, you get the Assertion every time you get a Download Error -228 when you try to download/install a Extension from AMO. Like "now" on https://addons.mozilla.org/en-US/firefox/addon/689
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475526
(Reporter)

Comment 4

9 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.