When PDF is embedded into HTML, FireFox 3 Beta 5 Will EASILY Crash

VERIFIED WORKSFORME

Status

()

Firefox
General
--
critical
VERIFIED WORKSFORME
10 years ago
10 years ago

People

(Reporter: lmcquarr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
On our external browser test site, we have a number of examples of PDF embedded in HTML using both an object tag and the embed tag.  

This is a new regression in Firefox 3 beta 5.  This problem does NOT happen in Beta4 and Beta 3.


Pretty much every one of them will quickly crash in Firefox with this sequence:

0 - Install the free Adobe Reader from: 
http://www.adobe.com/products/acrobat/readstep2.html

1 - view the embedded PDF page (see below for some URLs)
2 - go back to a non pdf page
3 - go forward to that embedded pdf again.

It seems as if after you view one of the above, Firefox 3 beta 5 is doomed to crash no matter what you do.



Here are some pages to try:
http://acroeng.adobe.com/Test_Files/embedded/simple-embed.html
http://acroeng.adobe.com/Test_Files/embedded/embed2.html
http://acroeng.adobe.com/Test_Files/embedded/embedded_big.html
http://acroeng.adobe.com/Test_Files/objecttest/obj_test/pdf_in_html.htm
http://acroeng.adobe.com/Test_Files/objecttest/firefox_ie_object_tag_forms.html

Comment 1

10 years ago
Works for me, Firefox 2008042305 on Windows XPSP2, Adobe Reader Plugin 8.1.2
I can reproduce the crash in 3.0b5 though, so I think this bug has
been fixed in the latest trunk builds, please verify:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 2

10 years ago
Yes, it is fixed in the latest trunk.  Hooray!  Thank you! 
(We have some very large mutual customers who use PDF embedded in HTML extensively for forms solutions.)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.