PSM keeps opening threads

VERIFIED WORKSFORME

Status

P3
critical
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: hacker, Assigned: ddrinan0264)

Tracking

1.0 Branch
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I recently installed PSM 1.1 for Mozilla (M16 build 2000061311) from the web
site pointed to on the main mozilla.org page (http:
//docs.iplanet.com/docs/manuals/psm/psm-mozilla/index.html).  While browsing
egghead.com (multiple windows were open, all browsing on this site -- but
notably, none were using secure connections), I noticed that my computer was
bogging down.  I opened up WinTop to close down Mozilla when I saw that what was
really slowing my computer down was Mozilla's PSM.EXE, which was using over 50%
of the CPU's resources.  Not only did I find it strange that it was open even
though I was not on a secure site, but it was rapidly creating new threads,
eating up my system and CPU resources.  Windows crashed before I could close
PSM, but at the time Windows crashed, WinTop counted 975 threads belonging to
PSM.EXE, which is obviously not normal behavior.  I'll try to duplicate this if
I can to give more specific information about when this happens.

Comment 1

18 years ago
Marking Worksforme. Using Win98 and WinNT, Wintop, and Mozilla build 2000061908. 
Psm.exe generally had 5 threads open even with multiple windows open, and all 
of the windows were pointing to secure sites. The most threads I ever saw was 7. 
Note: PSM.EXE will be loaded the first time it is needed, (to visit a https site 
or open the Security Advisor), and stays loaded until Mozilla is shut down.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

18 years ago
I figured out how to reproduce this.

1.  Go to www.egghead.com.
2.  Enter "Strobe Pro" (without quotes) into the "Search" box and click Search.
 (I highly doubt that a search for Strobe Pro specifically causes this, but
other searches don't routinely cause this problem; searching for Strobe Pro is
for some reason or another a reproducible problem.)
3.  At this point, my computer *usually* opens up PSM, which starts creating
threads.  If this doesn't work, then open up the Strobe Pro product information
in a new window (from the right-click menu) which always opens up PSM on my PC.

I'll see if I can duplicate this on other computers.  This doesn't appear to be
build-specific, because I downloaded 2000061908 and it's still there.  What's
really bizarre about this is that PSM shouldn't be open at all, because I'm not
viewing _any_ secure pages, nor have I viewed any during that browsing session.
 (Mozilla doesn't ask to open PSM, either; nor does it indicate that it's going
to do so.)

Comment 3

18 years ago
Verified. I'm still not seeing a problem even with 8 secure windows open.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm1.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.