Profile does not load successfully when $HOME is CIFS

RESOLVED DUPLICATE of bug 434307

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 434307
10 years ago
10 years ago

People

(Reporter: Rob Shinn, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.13) Gecko/20061201 Epiphany/2.18 Firefox/2.0.0.13 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

If the $HOME directory is mounted on a CIFS file system, then the default profile does not load.

Reproducible: Always

Steps to Reproduce:
1. Mount $HOME on CIFS w/Unix extensions (Samba server)
2. Start firefox

Actual Results:  
No bookmarks, default home page, etc. appear

Expected Results:  
Profile should load; bookmarks should appear, default home page should appear.
(Reporter)

Comment 1

10 years ago
Created attachment 318062 [details]
Samba configuration for CIFS server
(Reporter)

Comment 2

10 years ago
cifs client 1.47 in Linux Kernel Display Internal CIFS Data Structures for Debugging

/proc/fs/DebugData:
---------------------------------------------------
CIFS Version 1.47
Active VFS Requests: 0
Servers:
1) Name: 127.0.0.1  Domain: DOMAIN Mounts: 4 OS: Unix  
        NOS: Samba 3.0.24       Capability: 0x80e3fd
        SMB session status: 1   TCP status: 1
        Local Users To Server: 1 SecMode: 0x3 Req On Wire: 0
MIDs:

Shares:
1) \\server\muzak Uses: 1 Type: NTFS DevInfo: 0x0 Attributes: 0x2b
PathComponentMax: 255 Status: 1 type: 0 
2) \\server\images Uses: 1 Type: NTFS DevInfo: 0x0 Attributes: 0x2b
PathComponentMax: 255 Status: 1 type: 0 
3) \\server\projects Uses: 1 Type: NTFS DevInfo: 0x0 Attributes: 0x2b
PathComponentMax: 255 Status: 1 type: 0 
4) \\server\user1 Uses: 1 Type: NTFS DevInfo: 0x0 Attributes: 0x2b
PathComponentMax: 255 Status: 1 type: 0 
----------------------------------------------------------------------------
/proc/fs/cifs/LinuxExtensionsEnabled:
1
/proc/fs/cifs/OplockEnabled 
1
morgan@dagda:~$ cat /proc/fs/cifs/SecurityFlags
0x7

command to mount $HOME:

mount -t cifs -o rw,mand,user=user1 //server/user1 /home/user1
(Reporter)

Comment 3

10 years ago
Created attachment 318080 [details]
strace -f -o firefox.strace /usr/local/firefox/firefox
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?
I don't think this blocks unless this is a regression from Fx2, but I don't think it is.
Flags: blocking-firefox3? → blocking-firefox3-
(Reporter)

Comment 5

10 years ago
Well, it DOES work fine in Fx2.
(Reporter)

Updated

10 years ago
Flags: in-testsuite?
Flags: in-litmus?
Flags: blocking1.8.1.15?
Flags: blocking-firefox3?
Flags: blocking-firefox3.1?
Flags: blocking-firefox3-
Not sure why you would ask for it to block Firefox 2.0.0.15 when you say it works there so please don't mass request flags that you don't understand.
Flags: in-testsuite?
Flags: in-litmus?
Flags: blocking1.8.1.15?
Flags: blocking-firefox3? → blocking-firefox3-

Comment 7

10 years ago
My $HOME is mounted on a CIFS file system too. FF-3 doesn't start.
As workaround a symbolic link to the local file system (ln -s .mozilla /anywhere/local) works.
FF-2 works with ($HOME on) CIFS.

I'll attach the strace output too.

Comment 8

10 years ago
you can find the strace output there: http://maxdata.auto.tuwien.ac.at/ff.strace (it's too big to be attached)

Comment 9

10 years ago
This is similar to the problem I've described in Bug 434307.  In my case, just the .mozilla directory is on a CIFS file system.  Worked just fine with Firefox 2.x, but Firefox 3.0 doesn't like it and can't even create a new profile successfully on a CIFS file system.
(Reporter)

Comment 10

10 years ago
I will confirm that the behavior in the FF3.0 release is identical to Curt Shroeder's problem, and also note that Bug 434307 should probably be marked as a duplicate of this bug, since his behvavior also shows up only on CIFS (right, Curt?)

Comment 11

10 years ago
Actually, I would recommend this bug be marked as a duplicate of Bug 434307, as that bug report involves more than one file system type.
(Reporter)

Comment 12

10 years ago
Doesn't matter to me. I would just like to see this fixed.

One note: I've tried this both with and without the Linux CIFS client 'serverino' option (other applications, esp. KDE applications break without 'serverino') and the behavior is identical.  

The problem is probably related to file locking.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 13

10 years ago
can someone mark this bug as a dup of #434307?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking1.9.1?
Resolution: --- → DUPLICATE
Duplicate of bug: 434307
You need to log in before you can comment on or make changes to this bug.