Compiler-based depend is broken. Rebuilds everything on second pass

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
20 years ago
14 years ago

People

(Reporter: slamm, Assigned: slamm)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

20 years ago
The compiler-based dependecies have a problem that causes objects to be rebuilt
when they are up to date.

Here's what happens,
1. Build a fresh tree.
2. Build again without clobber. Everything gets rebuilt!
3. Build again without clobber, dependencies work properly.

I know what's happening and I have a fix (in config/rules.mk).
I will check it in when the tree opens, or sooner if the problem is considered
serious enough.
(Assignee)

Updated

20 years ago
Summary: Compiler-based depend is broken. Rebuilds everything on second pass
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 1

20 years ago
I checked in a fix.
If this does not work, I would suggest pulling the *.pp files out of the .deps
directory. This is what the plain vanilla -MD flag does. It's simpler, but then
you see all the extra files in your object directory.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.