If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

moving folder of bookmarks does now work correctly

RESOLVED DUPLICATE of bug 425884

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 425884
10 years ago
8 years ago

People

(Reporter: Filipe Moreira de Oliveira, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

I'm trying to import my Firefox 2 bookmarks, and they are fully restored to Bookmarks Menu.
But then I try to copy or move them to Bookmarks Toolbar...
I've got single bookmarks out of folders, folders with some bookmarks, and then folders with bookmarks and subfolders with more bookmarks.
The single bookmarks are ok. The folders and their bookmarks are ok too.
But the subfolders contents are corrupted. The subfolders itself are copied, but that doesn't happens with their contents.

Reproducible: Always

Steps to Reproduce:
1. Import a bookmarks file with tons of links, folders with links and subfolders with links too.
2. Try to copy or move them to Bookmarks Toolbar.
3. And subfolders content are corrupted.
Actual Results:  
Subfolders contents were lost, they didn't copy or move. The parent folders are ok.

Expected Results:  
Copy or move everything.

That was not a crash actually.
(Reporter)

Comment 1

10 years ago
Created attachment 318031 [details]
That's the current result. Even the subfolder contents are ok after restoring from file, this happens just after copying/moving.
(Reporter)

Updated

10 years ago
Attachment #318031 - Attachment description: That's the current result. → That's the current result. Even the subfolder contents are ok after restoring from file, this happens just after copying/moving.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk

Comment 2

10 years ago
a fix for copying folders has already been checked in some day ago, please test with the latest nightly

Comment 3

10 years ago
should have been fixed by bug 425884
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Summary: Bookmarks moving → moving folder of bookmarks does now work correctly
Duplicate of bug: 425884
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.