If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird crashes @nsDocument::GetScriptGlobalObject() on closing if drop down menu still visible

RESOLVED FIXED

Status

()

Core
General
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Willie Reid, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042806 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042803 Thunderbird/3.0a1pre ID:2008042803

On closing Thunderbird using top-right X, Thunderbird crashes if a drop-down menu on the toolbar is still visible.

Reproducible: Always

Steps to Reproduce:
1. Open drop-down menu (e.g. Tools) but do not choose from it.
2. Hit top-right X to close Thunderbird.
3.



I know this is an unusual transaction as normally you wouldn't close the app while a menu is visible. Indeed it happened first by accident.

Comment 1

10 years ago
For crashes, always give the crash id. You can get it e.g. by setting your mail start page to about:crashes. Paste the crash id here, prefixed with bp.
(Reporter)

Comment 2

10 years ago
Sorry.

bp http://crash-stats.mozilla.com/report/index/c0e06a35-153d-11dd-bc90-001cc45a2ce4
(Reporter)

Comment 3

10 years ago
Doubly sorry - ignore comment #2

bp http://crash-stats.mozilla.com/report/index/fccbb46b-1540-11dd-9a34-001cc45a2c28

Updated

10 years ago
Component: General → General
Product: Thunderbird → Core
QA Contact: general → general
Summary: Thunderbird crashes on closing if drop down menu still visible → Thunderbird crashes @nsDocument::GetScriptGlobalObject() on closing if drop down menu still visible
This looks pretty much like the problems caused on the Firefox build due to the
checkin of bug 428672, which was subsequently backed out. Unfortunately, our
nightlies were generated during the period which the patch was in.

I've now clobbered the nightly builds, new builds should be available in a few
hours. I'm fairly confident this will fix the problem, so marking as fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.