History dropmarker hover state is too subtle; looks like a mistake

RESOLVED FIXED in Firefox 3.7a2

Status

()

--
trivial
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: 32768, Unassigned)

Tracking

3.0 Branch
Firefox 3.7a2
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042806 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042806 Minefield/3.0pre

The hover state for the history dropmarker (when there is a history) causes the dropmarker to shrink so subtly that the difference is almost undetectable.

Please see attached screenshot.

If there is to be a different hover state at all, I believe it should be more obvious, to avoid looking like it is just a glitch rather than an intentional feature.

Reproducible: Always

Steps to Reproduce:
1. Click a link on a page (thus creating a history)
2. Hover over the history dropmarker in the keyhole

Actual Results:  
Dropmarker changes, but change is barely perceptible and looks like a bug

Expected Results:  
Hover state for dropmarker should be more obvious, if a hover state is used at all.  Similar dropmarkers have a gradient behind them on hover (or a lighter gradient if they already had a gradient).
(Reporter)

Comment 1

11 years ago
Created attachment 318298 [details]
Top: non-hover   Bottom: hover

Comment 2

11 years ago
Not sure if the new icon drop that's coming in soon (bug 430908) will do anything about that (it's supposed to add a hover state to that dropmarker, so I don't know if it would also improve on the hover state)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
It's not a mistake but rather an unintentional side effect of the change to the image for the hover state.  I thought about doing more elaborate states for the drop marker, but that isn't really platform native for how these types of drop markers usually behave (aside from the nav controls in vista).
The hover state is gone with bug 544999.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 544999
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a2
Version: Trunk → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.