Include multi-select custom fields in Bug.get output

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
WebService
--
enhancement
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: Frank Becker, Assigned: Max Kanat-Alexander)

Tracking

3.1.3
Bugzilla 4.0
Bug Flags:
blocking3.2 -

Details

(Whiteboard: [Fixed by blocker])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; de-de) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18
Build Identifier: Bugzilla 3.1.3+

multiselect field not in result of xmlrpc.cgi --bug_id

Reproducible: Always

Steps to Reproduce:
1. define a multi select custom field  named cf_multiselect
2.create a Bug and set the values
3. call xmlrpc.cgi with  --bug_id parm
Actual Results:  
field cf_multiselect is not returned

Expected Results:  
cf_multiselect with all selected values

Comment 1

10 years ago
Confirming. That's because $bug = new Bugzilla::Bug(), which doesn't collect data about multi-select fields when the object is created. Max, is that something we want to fix for 3.2?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking3.2?
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → 3.1.3

Updated

10 years ago
Summary: multi select custom fields not included in xmlrpc.cgi → multi-select custom fields not included when calling the Bug.get XML-RPC method
(Assignee)

Comment 2

10 years ago
  No, this isn't something we want for 3.2.
Severity: normal → enhancement
Flags: blocking3.2? → blocking3.2-
Summary: multi-select custom fields not included when calling the Bug.get XML-RPC method → Include multi-select custom fields in Bug.get output
Target Milestone: --- → Bugzilla 4.0
(Assignee)

Updated

8 years ago
Depends on: 573195

Comment 3

6 years ago
Fixed by bug 573195.
Assignee: webservice → mkanat
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Fixed by blocker]
Target Milestone: Bugzilla 5.0 → Bugzilla 4.0
You need to log in before you can comment on or make changes to this bug.