reduce size of VM used by build-graphs.mozilla.org

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: joduinn, Assigned: reed)

Tracking

Bug Flags:
needs-downtime +

Details

(Whiteboard: Thursday @ 7pm PDT 2008/05/15)

Currently this VM is 150GB. According to https://bugzilla.mozilla.org/show_bug.cgi?id=428617#c4, this VM no longer needs to be so large. mrz thinks this VM could be made smaller, and still run just the remaining build-graph processes.

Splitting out this project from bug#428617, which should track other build-machine cleanup work related to mothballing build-graphs.m.o.
This will need a downtime notice and a tree closure, since it takes a long time to copy 10 GB of data between two machines (especially since they're large DB files that get touched every time a tinderbox submits results), so it'll be nearly impossible to copy them all over and switch DNS between two tinderboxes reporting in.

I also vaguely recall it needing some Perl module that you couldn't get anymore, which we'll need to make sure we get copied over from the old machine by hand (or did it get rewritten to not need it? I forget).
Flags: needs-downtime+
(Assignee)

Comment 2

10 years ago
(In reply to comment #1)
> I also vaguely recall it needing some Perl module that you couldn't get
> anymore, which we'll need to make sure we get copied over from the old machine
> by hand (or did it get rewritten to not need it? I forget).

You're thinking of the pageload server, not build-graphs. Two different things entirely.

Comment 3

10 years ago
Intern project, moving.
Assignee: server-ops → nobody
Component: Server Operations → Server Operations: Projects
(Assignee)

Updated

10 years ago
Assignee: nobody → reed
(Assignee)

Comment 4

10 years ago
This is ready to go for tomorrow night's downtime window.
Status: NEW → ASSIGNED
Component: Server Operations: Projects → Server Operations

Updated

10 years ago
Blocks: 429338

Updated

10 years ago
Duplicate of this bug: 429338
(Assignee)

Updated

10 years ago
Whiteboard: Thursday @ ?pm PDT 2008/05/15
(Assignee)

Updated

10 years ago
Whiteboard: Thursday @ ?pm PDT 2008/05/15 → Thursday @ 7pm PDT 2008/05/15
(Assignee)

Comment 6

10 years ago
This was completed earlier tonight. I completed removed the old 160GB HD, but I did keep a 25GB copy of the data from the old VM, as I replaced it with a brand new RHEL5 VM. If everything checks out for a week or so, I'll remove the backup.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 7

10 years ago
I think you can remove that copy?
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> I think you can remove that copy?

Yep, I'll do that in a bit.
(Assignee)

Comment 9

10 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > I think you can remove that copy?
> 
> Yep, I'll do that in a bit.

Done.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.