Firefox automatically goes back one page when clicking on history button in menu bar

RESOLVED DUPLICATE of bug 406646

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 406646
10 years ago
10 years ago

People

(Reporter: Stephen Chou, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [same cause as bug 406646])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre

Sometimes, when I try to browse the history menu by clicking on the "history" button in the browser menu bar, the menu does not show. Instead, Firefox automatically goes back one page.

Reproducible: Sometimes

Steps to Reproduce:
1. Click on "history" button in menu bar.
Actual Results:  
Firefox automatically goes back one page.

Expected Results:  
History menu should appear, and Firefox should not go back one page.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042922 Minefield/3.0pre

WFM. Does this also happen in safe-mode? Are you using some userChrome.css?
Is your Back button directly below your History menu button? Only 2 pixels separate them from each other if I place some other toolbar buttons before the Back button.
(Reporter)

Comment 2

10 years ago
The problem happens in safe mode as well. I am currently using the default, unaltered theme for Vista (so the back button is not near the history menu button).
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081105 Firefox/3.0

Confirmed on XP - this is annoying the hell out of me - I have been encountering it on the 9/7 build as well, but I thought it was just me. I can get it multiple times in a session but I'm not sure what are the damn steps to speed up the encounter as they seem to be totally random. Using Default theme as well.
see related bug about the bookmarks menu bug 442177. I can confirm I get this behavior as well, although only sporadically and only when I had Kaspersky 2009 installed, see bug 454693.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
This seems a duplicate of Bug 442177. This problem can affect all menus, not only bookmarks menu.

Comment 6

10 years ago
(In reply to comment #5)
> This problem can affect all menus, not only bookmarks menu.

Exactly, the same for all menus, but more visible on history and bookmarks because their binding is more complex and they contian more elements (so are somehow slower)

Updated

10 years ago
Duplicate of this bug: 459003
Has this been fixed by bug 406646?

Comment 9

10 years ago
fixed with bug 406646, the cause is the same.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Depends on: 406646
Resolution: --- → FIXED
Whiteboard: [same cause as bug 406646]
to better follow changes in bug 406646 i'm going to mark this as its dupe. Cause IS the same even if that bug is more bind to bookmarks menu, but the issue is valid for every menu.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 406646
You need to log in before you can comment on or make changes to this bug.