If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

launching FF for reftest run gives JS warnings

RESOLVED DUPLICATE of bug 420084

Status

Testing
Reftest
RESOLVED DUPLICATE of bug 420084
10 years ago
9 years ago

People

(Reporter: Ray Kiddy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
The invocation of the app was this:

NO_EM_RESTART=1 ../browser_20080429_112838/mozilla/dist/MinefieldDebug.app/Contents/MacOS/firefox -profile /Users/ray/mo/tests_20080106_160400/debug.mozilla_20080106_173138_PST -reftest testing/reftest/libpr0n/reftest.list

This was in the output:

JavaScript strict warning: chrome://reftest/content/autoconf.js, line 262: redeclaration of property JPEG_CFLAGS
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 263: redeclaration of property JPEG_REQUIRES
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 267: redeclaration of property ZLIB_CFLAGS
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 268: redeclaration of property ZLIB_REQUIRES
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 272: redeclaration of property BZ2_CFLAGS
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 273: redeclaration of property BZ2_REQUIRES
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 277: redeclaration of property PNG_CFLAGS
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 278: redeclaration of property PNG_REQUIRES
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 282: redeclaration of property LCMS_REQUIRES
JavaScript strict warning: chrome://reftest/content/autoconf.js, line 298: redeclaration of property DLL_SUFFIX
JavaScript strict warning: chrome://reftest/content/reftest.js, line 83: reference to undefined property CC[NS_REFTESTHELPER_CONTRACTID]
autoconf.js is generated from autoconf.mk, which apparently redeclares variables.
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/layout/tools/reftest/Makefile.in&rev=1.12&mark=116-123#116

I don't think this is worth fixing. I think you should just disable strict warnings in the profile you use for reftest.
I want to stop using autoconf.js the way it is anyway.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Component: Testing → Reftest
Product: Core → Testing
QA Contact: testing → reftest
Resolution: --- → DUPLICATE
Version: Trunk → unspecified
Duplicate of bug: 420084
You need to log in before you can comment on or make changes to this bug.