bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox hangs when attempting to print a page containing SVG object tags

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Colin Adams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

I can print a pure SVG file.

When I try to print an XHTML page which contains object tags, printing hangs at the prepare stage (a dialog box comes up saying: "Progress: preparing", and then there is no more response. I have to kill FireFox and restart).
If I cut down the number of graphs and tables, then it prints OK.

Further checking shows that the Firefox process is using 100% of one CPU.

The same happens if I try inline SVG.

Anyway, I left the printing attempt running overnight. It still hasn't finished,
so I have had to kill Firefox.

I will prepare some attachments (I have to scramble some business-sensitive data first).

Reproducible: Always

Steps to Reproduce:
1. 
2.
3.
Does this happen on a recent trunk nightly?

Updated

10 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

10 years ago
I don't know.

I only have a regular production version. Is there a binary download for Windows available somewhere?
(Reporter)

Comment 4

10 years ago
It works beautifully with that version (and another layout problem for SVG with overflow: hidden on the containing div that I was about to report is also cured).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Great.

By the way, we use a resolution of WORKSFORME to mean that the problem is fixed but we don't know why. FIXED means we know what fixed it.
Component: General → SVG
Product: Firefox → Core
Resolution: FIXED → WORKSFORME
Version: 2.0 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.