Cyrillic text don't appear correctly when submitted in a form. [form sub]

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED WORKSFORME
18 years ago
15 years ago

People

(Reporter: Eugene Savitsky, Assigned: Alexandru Savulov)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Enter some cyrillic word and try to translate it to engish. Nothing happends.

Comment 1

18 years ago
I am guessing this is either a form submission issue or an editor issue. Eirc, 
I'll start with you.
Assignee: rods → pollmann

Comment 2

18 years ago
Basically, I think I am able to reproduce this bug.

1) Cut and paste the text below PROMT's Online Translator Powered by PITS
(I'll try here, no guarantee's this is right: Перевод будет выполнен в)
2) Click the translate button (Перевести, leftmost, between two textareas)
3) You should see the page reload, the top area should contain the same text, 
and the lower text area should read (in English):
Translation will be executed

In today's build, the lower text area is blank.
Status: NEW → ASSIGNED

Comment 3

18 years ago
The text is wrong, but following the directions, you should be able to reproduce 
the bug.
This bug has been marked "future" because the original netscape engineer working
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way
-- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future
(Reporter)

Comment 5

18 years ago
Hmmm. Tried this issue on http://www.lingvo.ru/lingvo/index.asp and it doesn't 
worked (had a message "none text were entered" or similar one), but when I 
reloaded the page all works now (cannot test originally reported URL coz it does 
not work at moment). I'll test it at the end of next weekend.

PS It's dogfood for me (at least 10 times a month)...

Comment 6

18 years ago
Updating QA contact.
QA Contact: ckritzer → vladimire

Comment 7

18 years ago
There are cirtainly problems submitting the form at the URL, but they dont 
happen 100% of the time. Sometimes it works sometimes it doesnt...

Comment 8

17 years ago
This is a really nasty bug, since neither Mozilla nor NN6 release allows any
cyrillic input to be submitted via POST (at least on Linux), which renders the
browser pretty much useless -- websites receive all client input as question marks.

Comment 9

17 years ago
I believe some people cannot reproduce it because of Content-Type 'charset'
setting. Mozilla submits Cyrillic forms pretty well when neither the page sets
any Cyrillic charset in Meta tag nor the server sets it in response headers.
While the charset in use is iso8859-1 or undefined at all, things go well. But
try to set Meta to charset=windows-1251 or koi8-r, and here it is: all Cyryllic
letters  are being submitted as question signs.

Comment 10

17 years ago
It also should be noted that this doesn't happen on every linux platform. I've
had this problem on RedHat 7.0, but when I moved to SuSE 7.0 this problem didn't
occur for me any more -- all cyrillic text gets submitted as it should. However,
people in russian linux newsgroups keep complaining about forms being submitted
as question marks, so this problem is apparently still present.

Comment 11

17 years ago
See bug 62522, can anyone here try out those two changes and see if it fixes the
problem for them?

Thanks!

Comment 12

17 years ago
In Solaris,

we cannot input any Thai text into the html form
(but for the UI component, like url address field - we can)

anyway we can copy text form elsewhere and paste it in mozilla,
and mozilla can display it quite well.



Bulk reassigning form bugs to Alex
Assignee: pollmann → alexsavulov
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
Summary: Cyrillic text don't appear correctly when submitted in a form. → Cyrillic text don't appear correctly when submitted in a form. [form sub]

Comment 14

16 years ago
This works for me now, build 2002-10-18-08-trunk
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 15

15 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.