Lightning should also display incoming ICS data (body/attachment) with opened message

RESOLVED WONTFIX

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
--
enhancement
RESOLVED WONTFIX
10 years ago
8 years ago

People

(Reporter: Günter, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 

Current version (0.8/0.9pre) of LG/SB (??) shows an invitation with an opened message, but does give the user the possibility to access the orginal ICS data contained in the message. There are only the invitation bar and the buttons for ACC/DECL/etc.
This disables the user to store the orginal ICS data for further / other use in his/her application environment.

Reproducible: Always

Steps to Reproduce:
1.receive TB message with invitation (ICS) data (body or/and attachment)
2.open the message from pane



Expected Results:  
Should after displaying the invitation infos (as LG does right now) include the original data. In form of body or as a attachment (depends on how the orginal messages contains it)
(Reporter)

Comment 1

10 years ago
Sorry read:
Current version (0.8/0.9pre) of LG/SB (??) shows an invitation with an opened
message, but DOESN'T give the user the possibility to access the orginal ICS data
contained in the message.

Comment 2

10 years ago
This is controlled by Thunderbird via menu View -> Display attachments inline. Disable it to see the .ics attachments.
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> This is controlled by Thunderbird via menu View -> Display attachments inline.
> Disable it to see the .ics attachments.
> 
This partially right: if the msg contains the ICS data as an attachment than it will be shown (with enable and disable).

Some calendar apps (like some OL versions) ONLY send ICS data inline/contained in the body. In this case there is NO method to get the original ICS data with LG enabled.

How to handle that situation ??

Comment 4

10 years ago
I'm curious how often you need to do this, and maybe you can post a specific example of why this is necessary.

Otherwise, for infrequent situations, it seems simple enough to view the message source in Thunderbird and copy/paste the meeting request to a file.

Personally I think it's better to hide the .ics attachment so it doesn't confuse normal users (who probably never want to look at the raw ICS data anyway).  Of course a hidden pref would solve this problem.
(Reporter)

Comment 5

10 years ago
> I'm curious how often you need to do this,

I'm using ReminderFox in parallel (maybe only one example not only to use LG) because there other features avaiable!! 

It's (as said w #3) no problem with ICS attachments, but with inline/body included ICS data! TB/LG just doesn't show them.

>it seems simple enough to view the message source in Thunderbird
NOT a user friendly solution ... NOT AT ALL !

TB/LG should NOT change the original data presentation.. that's the point!

Comment 6

10 years ago
Could you export and attach an email message that shows the issue?
Summary: LG should ALSO display incoming ICS data (body/attachment) with opened message → Lightning should also display incoming ICS data (body/attachment) with opened message
(Reporter)

Comment 7

10 years ago
Created attachment 319299 [details]
OL2003 invitation not show as 'original' ICS data w LG0.9pre

Posted file was send with OL2003 to a imap account.
Receiving it with TB 2.0.0.14/and LG 0.9pre (build 2008042811) the calendar bar
is show, also the ACC/DECL button. The body has some informations about the
invitation, but there is no 'orginal' data available.
I know it's accessible with 'source' ...

Comment 8

9 years ago
(In reply to comment #3)
> Some calendar apps (like some OL versions) ONLY send ICS data inline/contained
> in the body. In this case there is NO method to get the original ICS data with
> LG enabled.
> 
> How to handle that situation ??
This bug is probably a wontfix because I doubt Lightning / Thunderbird would treat specially case of invitations contained in the body.
Without Lightning you have to copy contents of the body, with it you just press Ctrl+U (or e.g. F9 after keyconfig-ing) and copy the invitation.
What do you want to do later after copying, do you do it often ?
Do you want to see invitations contained in the body as attachments so you could import them to the ReminderFox ?
If this is the case than this bug is more related to the Outlook / ReminderFox and not Thunderbird / Lightning.
I think we should be showing a user-friendly view of the event, not the original event data. The latter is usually only interesting for developers and power users, so I think its not too much to ask to view the source of the message.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.