Firefox leaks when you delete a history/bookmark item in the places library/organizer

VERIFIED FIXED

Status

()

defect
P2
normal
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({memory-leak})

Trunk
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Posted file leak log
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008043013 Firefox/3.0pre

Steps to reproduce:
-> Open Firefox - Go to Bookmarks -> Organize Bookmarks or History -> Show all History
-> Delete a item bookmark/history entry
-> Close Firefox
--> Leak !

Requesting blocking :( because of common scenario (deleting bookmarks).

Highest value during testing:
 => mAllocCount:          36574
 => mReallocCount:         4737
 => mFreeCount:           34793  --  LEAKED 1781 !!!
 => mShareCount:          34029
 => mAdoptCount:           2711
 => mAdoptFreeCount:       2709  --  LEAKED 2 !!!

 0 TOTAL                                          25   415811  1731183    13285 ( 4912.13 +/-  4171.76)  3522009     8547 ( 3534.88 +/-  5454.23)
Flags: blocking1.9?
Summary: Firefox leaks when you delete a history → Firefox leaks when you delete a history/bookmark item
Posted file new leak log
i think this leak might be related to Bug 423213 (different OS here), even i'm able to reproduce this leak also when i closed the Places Library after i deleted some items (as example history items) AND before i exit Firefox.

As example for the deleting of History items via the Places Library i'm able to leak more nsXMLDocument's , in this testcase with deleting 3 items:

691 nsXMLDocument                                 492     3936       42        8 (   22.84 +/-    11.32)    54158        9 (   83.51 +/-    21.95)

and in general this has result in :

nsTraceRefcntImpl::DumpStatistics: 742 entries
nsStringStats
 => mAllocCount:          28002
 => mReallocCount:         3658
 => mFreeCount:           25891  --  LEAKED 2111 !!!
 => mShareCount:          22297
 => mAdoptCount:           1384
 => mAdoptFreeCount:       1382  --  LEAKED 2 !!!

Running a full set of manual places testcases now.

Note: when you delete history items, you might crash because of bug 431346
wanted1.9.0.x+
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9-
So I'm confused. Do you only leak if you have the places library open when shutting down? Or all the time when a bookmark is deleted?
(In reply to comment #3)
> So I'm confused. Do you only leak if you have the places library open when
> shutting down? Or all the time when a bookmark is deleted?
> 

Ok did some testing here and seems there are 2 Scenarios :

1. Bookmarks

-> Firefox leaks when you delete bookmarks entries (as example from the unsorted bookmarks folder) and close Firefox WITH the Library open. When the Library is closed before, it does not leak

2. History

-> History is different, this leaks every time you delete a history entry, no matter if you close the Library before Firefox shutdown or not.

So i agree with wanted 1.9+
I can't reproduce this on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008051011 Minefield/3.0pre and at least in the case of leaking on history items I think you were seeing bug 433231.
Component: General → Places
Depends on: 433231
Flags: blocking1.9-
Product: Core → Firefox
QA Contact: general → places
Summary: Firefox leaks when you delete a history/bookmark item → Firefox leaks when you delete a history/bookmark item in the places library/organizer
Carsten, can you reproduce this now that bug 433231 is fixed?
fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre)
Gecko/20090114 Shiretoko/3.1b3pre by bug 433231  - not leaking anymore with the
steps to reproduce
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
verified per Leakcat comment #8
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.