Firefox crash after deleting History Item via Places Library [@ nsNavHistoryResult.h:429]

RESOLVED FIXED in mozilla1.9

Status

()

Toolkit
Downloads API
--
critical
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Tomcat, Assigned: Mardak)

Tracking

({crash})

Trunk
mozilla1.9
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has fix in bug 431346], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 318707 [details]
gdb data + DumpJSStack

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008043013 Firefox/3.0pre

Steps to reproduce: 
-> Was trying to get a DumpJSStack for my crash in Bug 431346
-> Open the Places Library - History -> Show all History
-> Select a few entries (i think my case around 10)
-> Context Menu -> Delete
--> Crash

i don't know why the Crash Data is different and not the same as https://bugzilla.mozilla.org/show_bug.cgi?id=431346#c13

the debug output shows the warning and then crash) (see the attachment for the complete data + DumpJSStack()

WARNING: Attempting to register an observer twice!: file /debug/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 3829

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000001
0x140a868e in nsNavHistoryVisitResultNode::GetTime (this=0x15b4d350, aTime=0x1) at nsNavHistoryResult.h:429
429	  NS_FORWARD_COMMON_RESULTNODE_TO_BASE
(gdb) bt
#0  0x140a868e in nsNavHistoryVisitResultNode::GetTime (this=0x15b4d350, aTime=0x1) at nsNavHistoryResult.h:429
#1  0x140a4040 in nsNavHistoryResult::OnEndUpdateBatch (this=0x15b42b30) at /debug/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp:4069
#2  0x14080ae8 in nsNavHistory::EndUpdateBatch (this=0x11de600) at /debug/mozilla/toolkit/components/places/src/nsNavHistory.cpp:3623
#3  0x1408bf11 in UpdateBatchScoper::~UpdateBatchScoper (this=0xbfffb66c) at /debug/mozilla/toolkit/components/places/src/nsNavHistory.cpp:263
#4  0x1408bf25 in UpdateBatchScoper::~UpdateBatchScoper (this=0xbfffb66c) at /debug/mozilla/toolkit/components/places/src/nsNavHistory.cpp:264
#5  0x14081c72 in nsNavHistory::RemovePages (this=0x11de600, aURIs=0x15fb6400, aLength=34, aDoBatchNotify=1) at /debug/mozilla/toolkit/components/places/src/nsNavHistory.cpp:3820
....
(Assignee)

Updated

10 years ago
Depends on: 431346
(Assignee)

Updated

10 years ago
Assignee: nobody → edilee
Component: Places → Download Manager
OS: Mac OS X → All
QA Contact: places → download.manager
Hardware: PC → All
Whiteboard: [has fix in bug 431346]
(Assignee)

Comment 1

10 years ago
http://hg.mozilla.org/cvs-trunk-mirror/index.cgi/rev/f29989c8508c#l2.7
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
(Assignee)

Updated

10 years ago
Duplicate of this bug: 431091
Product: Firefox → Toolkit
Crash Signature: [@ nsNavHistoryResult.h:429]
You need to log in before you can comment on or make changes to this bug.