Crash in [@ xpc_CloneJSFunction] on startup with lots of windows/tabs to restore

RESOLVED DUPLICATE of bug 434673

Status

()

Core
XPConnect
--
critical
RESOLVED DUPLICATE of bug 434673
10 years ago
7 years ago

People

(Reporter: David Caldwell, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

37.19 KB, text/plain
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18
Build Identifier: Firefox 3.0b5

I have about 40 windows in my current session. When I start firefox 3.0b5 it crashes about 75% of the time on startup. Every time I check the backtrace it is in the xpc_CloneJSFunction() function. It looks like that function is jumping to some random address.



Reproducible: Sometimes

Steps to Reproduce:
I get it mostly while starting up. I believe one of the backtraces provided was from a non-startup case, but many were from a few days ago and so I don't remember.



http://crash-stats.mozilla.com/report/index/ef5cd2ab-115d-11dd-b5d3-001321b13766?date=2008-04-23-17
http://crash-stats.mozilla.com/report/index/315dbb35-115f-11dd-bf78-001a4bd46e84?date=2008-04-23-18
http://crash-stats.mozilla.com/report/index/009c5b9e-1165-11dd-89a9-001cc45a2ce4?date=2008-04-23-18
http://crash-stats.mozilla.com/report/index/cf900bc7-156e-11dd-b7c5-001cc4e2bf68?date=2008-04-28-22
http://crash-stats.mozilla.com/report/index/76998ad1-1710-11dd-8ad2-001cc4e2bf68?date=2008-04-30-23

I had a few more when my network happened to be down and so the crash reporter couldn't send them. Is there any way to re-queue them back up?

Comment 1

10 years ago
Signature	xpc_CloneJSFunction(XPCCallContext&, JSObject*, JSObject*)
UUID	ef5cd2ab-115d-11dd-b5d3-001321b13766
Time	2008-04-23 10:51:02-07:00
Uptime	132
Product	Firefox
Version	3.0b5
Build ID	2008032619
OS	Mac OS X
OS Version	10.5.2 9C7010
CPU	x86
CPU Info	GenuineIntel family 6 model 7 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE
Crash Address	0xcbb215
Comments	
Crashing Thread
Frame 	Module 	Signature 	Source
0 	XUL 	xpc_CloneJSFunction 	mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp:76
1 	XUL 	XPCWrapper::GetOrSetNativeProperty 	mozilla/js/src/xpconnect/src/XPCWrapper.cpp:1394
2 	XUL 	XPC_NW_GetOrSetProperty 	mozilla/js/src/xpconnect/src/XPCNativeWrapper.cpp:528
3 	libmozjs.dylib 	js_NativeGet 	mozilla/js/src/jsobj.c:3543

that stack is fairly deep.

I personally blame PK11PasswordPrompt which imo should only make one call.
Component: Session Restore → XPConnect
Keywords: crash
Product: Firefox → Core
QA Contact: session.restore → xpconnect
Summary: Crash in xpc_CloneJSFunction on startup with lots of windows/tabs to restore → Crash in [@ xpc_CloneJSFunction] on startup with lots of windows/tabs to restore
Version: unspecified → Trunk

Comment 2

10 years ago
Created attachment 318749 [details]
stack
(Reporter)

Comment 3

10 years ago
Here's another I got today, in xpc_CloneJSFunction again:

http://crash-stats.mozilla.com/report/index/dc03c6fd-1886-11dd-825a-001a4bd46e84?p=1

This happened just while surfing, not starting up firefox.

Perhaps the Pk11PasswordPrompt is related to Bug 348997? At any rate the backtrace in this comment does not include any calls to Pk11PasswordPrompt.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 434673
(Assignee)

Updated

7 years ago
Crash Signature: [@ xpc_CloneJSFunction]
You need to log in before you can comment on or make changes to this bug.