NS_NOINTERFACE errors (Fallout from bug 413781)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: JoeS1, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Now that the console spam has diminished since bug 428600 fix,
I see the following console messages:

New message in inbox:
Error: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]
Source file: chrome://messenger/content/mail-folder-bindings.xml
Line: 132


Delete message in inbox:
Error: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]
Source file: chrome://messenger/content/mail-folder-bindings.xml
Line: 143


Send message: (assume item added to sent folder)
Error: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]
Source file: chrome://messenger/content/mail-folder-bindings.xml
Line: 132

These errors don't seem to effect functionaity in any way, but should
be addressed in the interest of a clean console for TB 3.0a1 release.
Flags: wanted-thunderbird3.0a1?
Duplicate of this bug: 432536
Joe, I don't see this on version 3.0a1pre (2008050210), have you got some steps to reproduce?
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Joe, I don't see this on version 3.0a1pre (2008050210), have you got some steps
> to reproduce?
> 
Nothing special, anytime a folder is changed (item added, or deleted) 
Started right after the che checkin for bug 413781
Still there in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050503 Thunderbird/3.0a1pre ID:2008050503

Note that bug 432536 noted them as well.
Haven't tried safe mode, but here's my extension list:
Console² 0.3.9
DOM Inspector 2.0.0
EditHtml 0.1.2
Lightning 0.6a1
Nightly Tester Tools 1.3
Provider for Google Calendar 0.4 [DISABLED]

I forgot to mention, I'm on Mac, so this could be Windows specific.
It's not Windows specific; I think it's "have a profile with one of the forms of broken half-server that Joey exposed." I'd bet that clean profile, click the link in bug 41133 comment 8 (and maybe restart, if that part's true), then delete mail would do it.
Yes i get this on linux (safe-mode too). I have only my first account set to check new mail automatically. I get the error if I click the "get mail" button, select an account from that dropdown list, and actually get some new mail.
(Reporter)

Comment 7

11 years ago
Further info:
This looks like a profile related problem, I'm no longer seeing the errors.
Prior to yesterday, I have been using a zip build and using software update to download partials, or full downloads as required. After installing an installer build on the same profile, the errors went away, even when I returned to the zip build. So something in the installer sequence did something to fix things.

I'll try to compare the saved profile with the resulting profile(after the installer) to see if I can pin it down.

This could explain why Magnus (linux) and Marsha (Mac) are both seeing the errors, since there is no intsaller with those builds.

Unrelated to this bug, use of the installer did change a few security prefs that I had set back to default values after the intall (that should not happen)

(In reply to comment #2)
> Joe, I don't see this on version 3.0a1pre (2008050210), have you got some steps
> to reproduce?
> 
So I'm now seeing this on my debug builds.
(Reporter)

Comment 9

11 years ago
The errors are back again for me.
The intaller build over my trunk profile chased them away, and partial software updates seemed to work OK.
The last thing I did was to install a full hourly zip over my existing build, and now they are back. Hope this gives someone a clue.

Marking as blocking Thunderbird 3 since this is a regression.
Flags: wanted-thunderbird3.0a1? → blocking-thunderbird3+
Keywords: regression

Comment 11

10 years ago
I'm pretty sure this was fixed by one of the other patches to the binding.
(Reporter)

Comment 12

10 years ago
I haven't seen these errors lately.
Will watch closely for the next few days, then WORKSFORME
(Reporter)

Comment 13

10 years ago
After 8-10 hours of runtime, none of the errors have occurred.
Marking worksforme for lack of a specific bug fix.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.