bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

firefox 3 beta 5 stops responding after saving file through "Right Click, Save Link As...". Download almost always never completes. This is used with Download Statusbar

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Rootbrian, Unassigned)

Tracking

({hang, stackwanted})

Trunk
x86
Linux
hang, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

Firefox 3, Beta 5 keeps crashing/not responding after saving a file using the "right click > Save link as..." menu. The download almost always never completes. This is done with download statusbar.

It's annoying when your saving a file to the desktop, when your default download dir is the Home folder (on Ubuntu linux).

I tried running it in safe mode, still, the bug is affecting me.

Reproducible: Always

Steps to Reproduce:
(Using download statusbar addon)
1. Go to website, any site.
2. Right clink on link to file/music stream/picture.
3. Click Save Link As...
4. Choose directory.
5. Click Save.
Actual Results:  
Firefox froze up (stopped responding) and had to be terminated. Same thing happens all the time.

Expected Results:  
Firefox asks you if you want to restore the session or start a new one.

Talkback seems to be disabled in Firefox 3 beta 5. Automatic bug reports are disabled. This should be re-enabled for it to autoreport the crashes/bugs found.

I can't re-enable it at all.
If you load about:buildconfig, you'll see that --disable-crashreporter is one of the configure arguments.

Can you try with a nightly build, please?  (It'll have breakpad.)
(Reporter)

Comment 2

10 years ago
I found the breakpad once I followed the directions you gave me.

How to use/enable it?

Since i'm not a developer, It's hard for me to fix stuff.

Ubuntu's updates doesn't let me automaticly update firefox until an update is available thru the Update Manager.

It's like that for everybody who uses ubuntu.
(In reply to comment #2)
> I found the breakpad once I followed the directions you gave me.
> 
> How to use/enable it?

Have you crashed the nightly build yet?  If so, breakpad should come up; it's not for general user-feedback submission, just for reporting crashes.
 
> Since i'm not a developer, It's hard for me to fix stuff.
> 
> Ubuntu's updates doesn't let me automaticly update firefox until an update is
> available thru the Update Manager.
> 
> It's like that for everybody who uses ubuntu.

We run Ubuntu too (and, to a lesser degree, Fedora Core).
I just noticed you say "not responding/crashing"--hangs won't trigger breakpad, only crashes; with the nightly build, can you still reproduce your hangs?
(Reporter)

Comment 5

10 years ago
The hangs can still be reproduced, but I can't resolve them unless I forcequit firefox, when restarted, brings up the restore session or start new session prompt. Either starting a new session and saving a link as or restoring the session and saving a link as, it does the same hang.

I haven't found a way to crash firefox by visiting a web page. I've noticed that some scripts (or overwhelming browsing) causes it to hang (firefox 1.5/2/3 beta 5) and I have to forcequit in order to restart it.

(Reporter)

Comment 6

10 years ago
I removed the download statusbar extension and it fixed the hanging problem. I'm going to reinstall it and see if the problem returns.
(Reporter)

Comment 7

10 years ago
The bug was fixed after re-removing the Download Statusbar.

The dev that made it didn't certify it was compatible with firefox 3 beta 5.

Thats the source of the hangs.

Sorry If I didn't test that out earlier.

Comment 8

10 years ago
if you can reproduce this on windows you can use:

http://en.wikipedia.org/wiki/Organisation_of_Rice_Exporting_Countries
debug>attach to process (select hung firefox)
(follow instructions from url)
!analyze -v -hang

if not, you can try installing a vendor build + debug symbols for everything used by firefox. or you can build your own build (--enable-debugger-info-modules).
http://www.mozilla.org/unix/debugging-faq.html
./run-mozilla.sh -g -d gdb ./firefox-bin
r
(hang firefox)
^C
thread apply all bt

attach whichever log you get.
Keywords: hang, stackwanted

Comment 9

10 years ago
oops, that first link was supposed to be:
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

someone poisoned my clipboard.
Version: unspecified → Trunk
(Reporter)

Comment 10

10 years ago
Firefox 3, beta 5 no longer crashes or hangs after removal of Download Statusbar 0.9.6.1.

The person/team who developed the download statusbar has to make a bug fix to correct the problem. So far, there's no contact information on who made the addon.

Clicking on the developer's name leads to a forum hosting the software, but no way to contact and inform of bugs relating to the extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.