right click drag from page to bookmarks toolbar yields strange context menu

VERIFIED DUPLICATE of bug 425575

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 425575
10 years ago
9 years ago

People

(Reporter: eleven81, Unassigned)

Tracking

({regression})

3.0 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050103 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050103 Minefield/3.0pre

Right clicking and dragging from anywhere on any page to the bookmarks toolbar, or even to a bookmark in the bookmarks toolbar, yields a context menu that's nearly 1000 pixels tall, and is filled with options that make no sense for a right click drag of nothing to the bookmarks toolbar.  Choosing any of the options on this context menu only dismisses the menu.

Reproducible: Always

Steps to Reproduce:
1. Quit and restart Minefield.
2. On any page, even about:blank, right click and drag to the bookmarks toolbar.
3. Release the right drag on the bookmarks toolbar.
Actual Results:  
The context menu that appears is filled with nonsensical options.
(Reporter)

Comment 1

10 years ago
Created attachment 318791 [details]
A screenshot of the context menu for bug 431664.
(Reporter)

Updated

10 years ago
Summary: right click drag from page to bookmark toolbar yields strange context menu → right click drag from page to bookmarks toolbar yields strange context menu

Comment 2

10 years ago
I can confirm.  I also wonder if it is related to bug 431535.  The error does not manifest itself if I first right-click on a valid bookmark item, which is also the same workaround for bug 431535.  Right-clicking on the bookmark toolbar also gives the same aNode is null error, so I suspect that bug 431535 may fix this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [possible fix in bug 431535?]
Version: unspecified → Trunk
Regression range:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-11-30+22%3A00&maxdate=2006-12-01+06%3A00
It is not clear what bug might have caused this, there are several possibilities.
Have just applied the patch in bug 431535, and this does not fix this error.

> Right-clicking on the bookmark toolbar also gives the same aNode is null error, 
> so I suspect that bug 431535 may fix this.

The aNode error appears any time that the bookmark toolbar has to test whether "Paste" should be enabled in the context menu. The patch in 431535 fixes this, and fixes the rogue context menu in that bug, but the context menu seen here will still occur by following STR above.

This is also present in Beta 4.

A workaround is to right-click to bring up the context menu in the page. You then get the correct context menu when following above.

Not a common use case, wanted rather than blocking?
The code that checks whether certain options should be enabled/disabled/shown at all is failing at:

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/browser/base/content/nsContextMenu.js&rev=1.59#420

causing the code to display all the possible options, and selecting their default enablements/disablements.

At this point aNode is a HTMLDocument, and target.ownerDocument = null.

I'm guessing that it doesn't make any sense for aNode to be a document, so a wallpaper solution would be to test for this and not show the context menu, but that wouldn't match FF2 behaviour (displays bookmark toolbar context menu).

Unlikely that it's bug 185239 that regressed this, as the changes to nsContextMenu are trivial. Perhaps bug 360731?

Whiteboard: [possible fix in bug 431535?] → regression
Marco, any idea which bug could have been caused this issue? Something you can see for the given regression range in comment 3?
Component: Bookmarks & History → Places
Keywords: regression
QA Contact: bookmarks → places
Whiteboard: regression
Version: Trunk → 3.0 Branch

Comment 7

10 years ago
(In reply to comment #6)
> Marco, any idea which bug could have been caused this issue? Something you can
> see for the given regression range in comment 3?

at a first glance i would tell bug 360731, but reason is not clear yet

Comment 8

10 years ago
but could also be bug 185239, hwv this does not only happen on the toolbar, you can drag to everywhere out of the content window and get the same problem

Comment 9

10 years ago
Having experimented around with this bug (currently running Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081211 Minefield/3.2a1pre (.NET CLR 3.5.30729)), i have noticed that, as mentioned before, dragging a right click outside the content panel causes the strange long context menu. However, not sure if its just a partial fix on the bug, it shows the last displayed context menu. 
To Reproduce, open new FF Window, and drag a right click outside the content window. As above, the long context menu appears. However, right click successfully, i.e. on an image, and then do the right-click and outside the content window, and it shows the last displayed context menu.
Curiously, not sure if it has any relevance in finding a solution, the problem only occurs in the content panel, dragging a right click from anywhere else on the page works as expected.

Updated

9 years ago
Duplicate of this bug: 480146

Comment 11

9 years ago
Ah, not the oldest one. ;)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425575
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.