Closed Bug 431707 Opened 14 years ago Closed 13 years ago

Remove phantom details pages for unsupported apps

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: baz, Assigned: wenzel)

References

Details

Attachments

(1 file)

There are public pages that are shown for ad

Examples include:

Enigmail
https://addons.mozilla.org/en-US/firefox/addon/71 
This is a Thunderbird add-on that has a page for App=Firefox

FireMacs
https://addons.mozilla.org/en-US/thunderbird/addon/4141
This is a Firefox only add-on that has a page for App=Thunderbird

Note that these pages are only accessible by hand-modification of the URL and are not indexed (but I'm not 100% certain).

We should only display an add-on details page for the apps that it supports.
These pages are indexed by google and thus lead people astray. E.g. searching for "keybind thunderbird" put FireMacs at the top Google result even though it doesn't work with Thunderbird.
Duplicate of this bug: 418925
Duplicate of this bug: 422217
Duplicate of this bug: 427056
Found a way to reproduce not by editing the URL, at least for experimental
add-ons: 

1. Log out of AMO
2. Find an "experimental" non-Firefox extension, like the Forward Extension :-)
   https://addons.mozilla.org/en-US/thunderbird/addon/7026
3. Try to download this extension
   https://addons.mozilla.org/en-US/thunderbird/users/login?to=%2Faddon%2F7026
4. Log in on the page and you end up on the Firefox URL:
   https://addons.mozilla.org/en-US/firefox/addon/7026
> 4. Log in on the page and you end up on the Firefox URL:
Onno, that's a different bug.
In comment #0 it reads:

Note that these pages are only accessible by hand-modification of the URL

If you want, I can file it as a new bug, because the title doesn't match, but I'm not sure it's another bug and have so many dupes behind my name already
Sure, file it as a new bug. I am pretty sure it's no dupe.
The behavior described in comment #5 has been filed as bug 434496 and fixed...
<a href="http://groups.google.com/group/mozilla.support.seamonkey/browse_thread/thread/6bae006122457d1c#">
Link to mozilla.support.seamonkey</a>

Using SeaMonkey 1.1.9

I wanted to install the Mycroft search add-on. I went to:

https://addons.mozilla.org/en-US/seamonkey/search?q=mycroft

I clicked on the Add to SeaMonkey button and received an error
message:

"Sorry, you need a Mozilla based browser (such as Firefox) to install
a search plugin"

Any thoughts? 

The issue here is basically that the extension, as linked by AMO, is not
compatible with SeaMonkey in its current form: AMO provides an
OpenSearch link only. OpenSearch is not supported by SM (yet). Mycroft
also offers a Sherlock version of its search [1], it's just that that
version is not linked from AMO. Feel free to file a bug at
bugzilla.mozilla.org against Product addons.mozilla.org or contact the
Mycroft developers. This might also be related to bug 431707 [2], but
I'm not sure.

[1]:
<http://mycroft.mozdev.org/download.html?name=mycroft&category=6&count...>
I got a support email asking me why my add-on failed to install in SeaMonkey 1.1.9 which is strange since my add-on doesn't support SeaMonkey.  The person got my add-on at https://addons.mozilla.org/en-US/seamonkey/addon/2324

I have no idea how they got to that page.
Duplicate of this bug: 420671
Another way to get to a phantom URL is when a user has add-ons for different applications. When you click from one add-on on the user and then on another add-on, you see the user profile and the next add-on on the same application as you started out on...
I dug up an example for my comment #13 :

1. Go to Firefox add-on Console² https://addons.mozilla.org/en-US/firefox/addon/1815
2. Click on user Philip Chee: https://addons.mozilla.org/en-US/firefox/user/408
3. Go to SeaMonkey only add-on xSidebar

And an unregistered end-user is on a phantom page, trying to install xSidebar to Firefox.
Blocks: 495351
Attached patch Patch, rev. 1Splinter Review
This is a shot at fixing this: It forwards to the first compatible app's sub-page if the add-on chosen is incompatible with the current app.

This will effectively get rid of the "phantom" pages. The only concern I have is that it may be confusing to the user -- yet less so than the current state. I suggest we get this patch in, and if we think we need UI improvements, we can file followup bugs.
Assignee: nobody → fwenzel
Status: NEW → ASSIGNED
Attachment #380510 - Flags: review?(clouserw)
Target Milestone: --- → 5.0.6
Attachment #380510 - Flags: review?(clouserw) → review+
Fixed in r26642. Thanks!
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED with the testcase in comment 0; loading https://preview.addons.mozilla.org/en-US/thunderbird/addon/4141 redirects me to https://preview.addons.mozilla.org/en-US/firefox/addon/4141.

Onno/Michael/others -- could use your help ensuring we didn't regress anything, here.
Status: RESOLVED → VERIFIED
Blocks: 497520
removing "push-needed" from 105 AMO 5.0.6 bugs; filter on "I hate stephend!"
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.