Closed Bug 431781 Opened 12 years ago Closed 10 years ago

Crash when opening saved page containing youtube video [@ _CopyCStringToPascal]

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: abillings, Assigned: msintov)

Details

(Keywords: crash, testcase, Whiteboard: 10.0.1.218)

Crash Data

Attachments

(2 files)

Attached file File with embed tag.
I saved a page which had an embedded youtube video. When I open the page, I crash.

I narrowed down the html to (in its entirety):

<embed src="THEGpbnp1tMhlen" type="application/x-shockwave-flash">

The "THEGpbnp1tMhlen" src is flash binary data saved when I saved the page. If I leave out the src attribute, it doesn't crash so I need an html page with just the above embed tag and the flash data.

I have good crash data at http://crash-stats.mozilla.com/report/index/7dc57b59-17d7-11dd-a305-001cc45a2ce4?date=2008-05-01-23.

I'm running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050104 Minefield/3.0pre on OS X 10.5.2. My Flash plugin is version 9.0 r124, which is the latest version.

Steps to Reproduce:
1. Save the two attached files to a local system.
2. Open the embed.html file in Firefox.

Result: crash
Attached file binary flash data
Keywords: crash
Severity: normal → critical
Keywords: testcase
Summary: Crash when opening saved page containing youtube video → Crash when opening saved page containing youtube video [@ _CopyCStringToPascal]
WFM, same build/Flash-plugin/OSX versions as above. (also WFM in debug build)

Al, do you crash in safe-mode too?
Tomcat repro'd the crash with a normal build using the same flash and OS X version.

I didn't use Safe Mode because it was a brand new and clean profile with no extensions or themes...
Oh, and Tomcat mentioned that his debug build wouldn't crash even though the normal one did on the same machine.
Signature	_CopyCStringToPascal
UUID	7dc57b59-17d7-11dd-a305-001cc45a2ce4
Time	2008-05-01 16:32:11-07:00
Uptime	44
Product	Firefox
Version	3.0pre
Build ID	2008050104
OS	Mac OS X
OS Version	10.5.2 9C7010
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE
Crash Address	0x933e695e
Comments	Loading a local <embed> with a flash file derived from saving a web page with youtube content.
Crashing Thread
Frame 	Module 	Signature 	Source
0 	CarbonCore 	_CopyCStringToPascal 	
1 	Flash Player 	Flash Player@0x37d0d9 	
2 	Flash Player 	Flash Player@0x1716ca 	
3 	Flash Player 	Flash Player@0x21b3a6 	
4 	Flash Player 	Flash Player@0x247dee 	
5 	Flash Player 	Flash Player@0x24b2d7 	
6 	Flash Player 	Flash Player@0x3bf9a0 	
7 	Flash Player 	Flash Player@0x3abb49 	
8 	XUL 	ns4xPluginInstance::HandleEvent 	mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp:1295
9 	XUL 	nsPluginInstanceOwner::Notify 	mozilla/layout/generic/nsObjectFrame.cpp:4165
10 	XUL 	nsTimerImpl::Fire 	mozilla/xpcom/threads/nsTimerImpl.cpp:403
11 	XUL 	nsTimerEvent::Run 	mozilla/xpcom/threads/nsTimerImpl.cpp:490
12 	XUL 	nsThread::ProcessNextEvent 	mozilla/xpcom/threads/nsThread.cpp:510
13 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:180
14 	XUL 	nsBaseAppShell::NativeEventCallback 	mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:121
15 	XUL 	nsAppShell::ProcessGeckoEvents 	mozilla/widget/src/cocoa/nsAppShell.mm:302
16 	CoreFoundation 	CFRunLoopRunSpecific 	
17 	CoreFoundation 	CFRunLoopRunInMode 	
18 	HIToolbox 	RunCurrentEventLoopInMode 	
19 	HIToolbox 	ReceiveNextEventCommon 	
20 	HIToolbox 	BlockUntilNextEventMatchingListInMode 	
21 	AppKit 	_DPSNextEvent 	
22 	AppKit 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
23 	AppKit 	-[NSApplication run] 	
24 	XUL 	nsAppShell::Run 	mozilla/widget/src/cocoa/nsAppShell.mm:591
25 	XUL 	nsAppStartup::Run 	mozilla/toolkit/components/startup/src/nsAppStartup.cpp:181
26 	XUL 	XRE_main 	mozilla/toolkit/xre/nsAppRunner.cpp:3170
27 	firefox-bin 	main 	mozilla/browser/app/nsBrowserApp.cpp:158
28 	firefox-bin 	start 	crt.c:272
29 	firefox-bin 	start 	
30 		@0x0
Assignee: nobody → msintov
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Thank you for the bug report. This bug should be fixed in the next Flash Player 10 beta (the version after 10.0.1.218).
Status: NEW → RESOLVED
Closed: 10 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Resolution: --- → FIXED
Whiteboard: 10.0.1.218
Target Milestone: --- → Jun 2008
Version: Trunk → 9.x
Target Milestone: Jun 2008 → Jul 2008
Crash Signature: [@ _CopyCStringToPascal]
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: Jul 2008 → ---
Version: 9.x → unspecified
You need to log in before you can comment on or make changes to this bug.