If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when starting java on a particular website

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Gunnlaugur Thor Briem, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

I am seeing a consistently repeatable crash on visualthesaurus.com when looking up a word. Java is working on other websites such as http://www.java.com/en/download/help/testvm.xml but seems to crash the browser on this one.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.visualthesaurus.com/
2. Type a word in the red box with the heading "Look up a Word:"
3. Click the button labeled "LOOK IT UP"
4. Observe the crashiness.
Actual Results:  
The Firefox window closes almost instantly. No dialog box or other message is displayed. When starting Firefox anew, I am invited to restore the session that crashed. That succeeds just fine, but if I try looking up a word again, I get this crash every time.

Expected Results:  
Expected the java applet to work, or at least fail without crashing the whole browser.

At http://www.java.com/en/download/help/testvm.xml I get the following information about my java setup:

Vendor: Sun Microsystems Inc.
Version: 1.6.0_05
Operating System: Windows XP
OS version: 5.1

While writing this, I'm noticing that there are four java icons in the system notification area ("tray") in the bottom right of the screen; presumably one for each browser crash while I was testing and retesting this.

Comment 1

10 years ago
The applet did not crash for me, with the latest hourly minefield build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050203 Minefield/3.0pre

However, my Java plugin is significantly newer as well:
Vendor: Sun Microsystems Inc.
Version: Java 6 update 5
Operating System: Windows XP
(Reporter)

Comment 2

10 years ago
I believe that's the same Java version, see http://en.wikipedia.org/wiki/Java_version_history ... don't know why the version string would be different.

I have several Java installations:

c:\Program Files\Java\jdk1.6.0_02
c:\Program Files\Java\jre1.6.0_02
c:\Program Files\Java\jre1.6.0_03
c:\Program Files\Java\jre1.6.0_05

of which the latest is apparently being used. Is it possible that the presence of the other installations triggers this?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050210 Minefield/3.0pre

Works fine here.
does the Firefox Crash reporter launch when you crash ? If so, can you provide the crashreporter url from about:crashes
Keywords: crash
Version: unspecified → Trunk
(Reporter)

Comment 5

10 years ago
Sorry, no, the crash reporter did not launch. The Firefox window and process just vanished without comment or apology.

I will try downloading a bleeding-edge build to see if I can reproduce this there.
It works for me.

From Comment #1:

> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5)
> Gecko/2008032620 Firefox/3.0b5

Mh. Why your Fx3 is named Firefox and not Minefield? Do you compiled it by yourself?

Try to uninstall it, reinstall the latest trunk and test the site in a new, clean profile:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 7

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0 ID:2008051206

Tried on the same machine with the above build ID --- an RC1 build, taken from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.0rc1-candidates/build1/ --- and could not reproduce this.
(In reply to comment #7)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206
> Firefox/3.0 ID:2008051206
> 
> Tried on the same machine with the above build ID --- an RC1 build [...] could 
> not reproduce this.

So can you change the bug resolution to WORKSFORME? Thanks :-)

(Reporter)

Comment 9

10 years ago
Yes, apparently I can. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.