pasting bookmarks to Bookmarks Toolbar fails

VERIFIED DUPLICATE of bug 431535

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 431535
10 years ago
8 years ago

People

(Reporter: Radek 'sysKin' Czyz, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050206 Firefox/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050206 Firefox/3.0pre

Context menu for bookmarks toolbar has "paste" item which doesn't work.

Reproducible: Always

Steps to Reproduce:
v1)
1. Ensure you have empty space in bookmarks toolbar
2. Copy a bookmark from somewhere
3. Right-click on that toolbar empty space, pick "paste"

v2)
1. Copy a bookmark from somewhere
2. Open bookmarks menu, right-click on static "Bookmarks Toolbar", pick "paste"
Actual Results:  
Paste fails.

Error: aNode is null
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/modules/utils.js
Line: 388


Expected Results:  
Bookmark pastes :)


Right-clicking on empty space (v1 step 3) also produces 4 other exceptions, but it's probably not related because v2 fails without them.
(Reporter)

Comment 1

10 years ago
Apologies, the exception "aNode is null" does NOT show up when using steps v2. It just fails. Also, v2 might not have "paste" at all, possibly because of bug 431535. It's random.
Blocks: 431535
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
No longer blocks: 431535
Depends on: 431535
The patch in bug 431535 fixes the above.

All the behaviour in both bugs is caused by testing to see whether the "Paste" command should be enabled (in bug 431535 because the toolbar tests this to decide 
whether to diable the paste command in the context menu, and in this bug because a test is performed to see if a command is enabled before executing it).

Another effect is that the paste command in this context menu will always be enabled, even when the clipboard is empty (the paste command in the Edit menu will be correctly enabled/disabled).

Based on above, dupe to 431535?
(In reply to comment #2)
> Based on above, dupe to 431535?

Marco, could you please solve it?
the context menu is messed up if you don't have a valid node selected, it's most likely a dupe of that
Status: NEW → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 431535
Resolution: --- → DUPLICATE
Duplicate of bug: 431535
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.