If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Navigator panel: home page location input field & radio buttons always blank

VERIFIED FIXED in M18

Status

SeaMonkey
Preferences
P2
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: matt)

Tracking

({regression, smoketest})

Trunk
regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+][nsbeta2+])

(Reporter)

Description

18 years ago
see this using 2000.06.20.08 commercial bits on all platforms.

1. open Preferences dialog.
2. go to Navigator category.
observe that the Location input field for specifying the home page is blank,
even if you click in it.

side note: still able to change [and save pref] the home page url.
(Reporter)

Updated

18 years ago
Keywords: nsbeta2, regression, smoketest
(Reporter)

Comment 1

18 years ago
okay, instead of filing a seperate bug on the radio button issue, i'll include
it here since it seems related.

basically, when i open up the Preferences dialog, the radio buttons for the
Navigator panel (controlling startup page for browser) are not initialized. you
can select one of them, and save that setting (OK prefs dialog) for that
session. if you quit and restart, the next session (as with the location input
field in the same panel) will display *no* selected startup page.

the danger with this is that, if you leave either the radio buttons unselected
or the location field blank *and* click OK to dismiss the prefs: the subsequent
session will display about:blank as the startup --effectively removing the
expected startup webpage info from your prefs. bumping sev to major.
Severity: normal → major
Keywords: dogfood
Summary: home page location input field always blank → Navigator panel: home page location input field & radio buttons always blank

Comment 2

18 years ago
*** Bug 43196 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
*** Bug 43198 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 43126
(Reporter)

Comment 4

18 years ago
adding Stephan and Decklin to cc list...
(Reporter)

Comment 5

18 years ago
*** Bug 43031 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
Putting on [dogfood+][nsbeta2+] radar.
Whiteboard: [dogfood+][nsbeta+]

Updated

18 years ago
Whiteboard: [dogfood+][nsbeta+] → [dogfood+][nsbeta2+]

Comment 7

18 years ago
Matt ...
Assignee: ben → matt
Priority: P3 → P2
Target Milestone: --- → M18

Comment 8

18 years ago
This is a timing problem.  initPanel() is getting called before Startup() and 
it looks for hPrefWindow, but at that time hPrefWindow is null because Startup
() hasn't executed yet.  This same exact problem also occurs when calling 
preferences from MailNews in the default pane.

Ben and I are looking at this (cc ben).

Comment 9

18 years ago
Bug 42850 deals with the same problem as this.  I'm reviewing the patch now to 
see if it fixes this...

Comment 10

18 years ago
decklin's patch worked, but there's a better one to fix the timing problem. ben 
just checked it in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

18 years ago
vrfy using 2000.06.23.08 comm bits on all/all.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.