CSS Padding crops cell width

RESOLVED FIXED in mozilla0.8

Status

()

P3
minor
RESOLVED FIXED
19 years ago
18 years ago

People

(Reporter: tony.gorman, Assigned: karnaze)

Tracking

({testcase})

Trunk
mozilla0.8
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix-in-hand, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Checkout the example.

CSS Padding-left and padding-right applied to content in a table cell seem to 
reduce the total width of the cell. The decrease seems to be directly 
proportional to the padding amounts.

Comment 1

19 years ago
*** Bug 43378 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
setting status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

19 years ago
Marc: rows, row groups, col groups, cols should have zero padding (zero margins 
also). In this case it looks like the row is getting a nonzero padding. The 
style system should probably deal with this to make it easier later on.
Assignee: karnaze → attinasi
(Assignee)

Comment 4

19 years ago
Forget the last comment, since arbitrary elements can be maped to rows and vice 
versa. This needs to be handled in the reflow state or table code. Reassigning 
back to me.
Assignee: attinasi → karnaze
(Assignee)

Comment 5

19 years ago
Created attachment 11174 [details] [diff] [review]
patch to fix the bug
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: fix-in-hand
Target Milestone: --- → M18
(Assignee)

Updated

19 years ago
Keywords: testcase

Updated

19 years ago
QA Contact: desale → chrisd
(Reporter)

Comment 6

19 years ago
Test URL has now changed. This is more a prompt for bug owner to put the patch
into the tree :-)

Comment 7

19 years ago
karnaze, can you get this reviewed and maybe checked into the trunk if it's too
late for the branch?

Comment 8

18 years ago
Chris,

I just looked into this bug with a rotten patch. May be you can help the patch
submitter to get the patch into the tree.

Bernd
(Assignee)

Comment 9

18 years ago
Marking mozilla0.8 (need to re-test the patch).
Target Milestone: M18 → mozilla0.8
(Assignee)

Comment 10

18 years ago
The patch was checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
QA contact update
QA Contact: chrisd → amar
You need to log in before you can comment on or make changes to this bug.