Status

()

Core
Canvas: 2D
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Alan Pae, Unassigned)

Tracking

1.8 Branch
x86
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9b5) Gecko/2008042914 Firefox/3.0b5
Build Identifier: Sunbird .8

ON=\"1.8\"  /build/mozilla/content/canvas/src/nsCanvasRenderingContext2D.cpp
"/usr/include/pango-1.0/pango/pangocairo.h", line 71: Error: cairo_font_type_t is not defined.
"/usr/include/pango-1.0/pango/pangocairo.h", line 73: Error: cairo_font_type_t is not defined.
2 Error(s) detected.
gmake[5]: *** [nsCanvasRenderingContext2D.o] Error 2
gmake[5]: Leaving directory `/build/mozilla/obj-sunbird/content/canvas/src'


Line 71-73 of pangocairo.h inclusive:

PangoFontMap *pango_cairo_font_map_new_for_font_type (cairo_font_type_t fonttype);
PangoFontMap *pango_cairo_font_map_get_default       (void);
cairo_font_type_t pango_cairo_font_map_get_font_type (PangoCairoFontMap *fontmap);


Reproducible: Always

Steps to Reproduce:
1.Use the following .mozconfig

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-sunbird
. $topsrcdir/calendar/sunbird/config/mozconfig
ac_add_options --enable-application=calendar 
ac_add_options --disable-debug 
ac_add_options --disable-tests 
ac_add_options --enable-static --disable-shared 
ac_add_options --enable-official-branding
ac_add_options --disable-auto-deps

2.Run gmake -f client.mk build

3.
Actual Results:  
The error in the details windows happens

Expected Results:  
build to finish

Please update the code to resolve the error message

Comment 1

10 years ago
This is a bug tracking software and not a support platform. I suggest that you check the mozilla forum, wiki and newsgroup first to get help. 
In addition moving to correct component.
Component: Build Config → Layout: Canvas
Product: Calendar → Core
QA Contact: build → layout.canvas
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

10 years ago
Ok, thanks, will try newsgroups.

alan

Comment 3

10 years ago
Based on the existence of official Sunbird 0.8 builds for Solaris x68 and Solaris SPARC this is probably no code error but an issue in your build system and libraries.
(Reporter)

Comment 4

10 years ago
Stefan,

I can't argue with your logic however my build system is merely a boring, mundane, ordinary installation of the OS and the compilers are installed by default as part of the OS installation.

I made no tweaks to either the OS or the build system.

Since the downloads are in different directories do you know of anyway to confirm that Sun did both builds?

thanks,
alan

Comment 5

10 years ago
(In reply to comment #4)
> Since the downloads are in different directories do you know of anyway to
> confirm that Sun did both builds?
Yes, Sun's OpenOffice team contributes the Solaris nightly and release builds.
(Reporter)

Comment 6

10 years ago
ac_add_options --disable-canvas 

resolves the issue
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 7

10 years ago
@Alan Pae: what version of solaris do you build with? 
(Reporter)

Comment 8

10 years ago
(In reply to comment #7)
> @Alan Pae: what version of solaris do you build with? 
> 

Solaris Developer Express 1.08 and OpenSolaris 200805.  Both had the exact same issue.

Sun Studio 12 with the patch for 1.08, and Sun Studio Express for OpenSolaris.

alan

Comment 9

10 years ago
the solaris version used to do the builds here is an older one and doesn't even know about cairo -> no problems here.
we'll probably hit that too when doing trunk builds on a newer solaris version.
(Reporter)

Comment 10

10 years ago
If/when you do and if you have a different solution then please post it.

Other then disable-canvas is there another way to mimic your environment; specifically build without cairo support?

thanks,
alan

Updated

10 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.