[BioTech Extension] Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Administration
RESOLVED INVALID
10 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050221 Firefox/3.0pre

Steps to reproduce:
-> Install the BioTech Extension https://addons.mozilla.org/en-US/firefox/addon/4473
-> Open the BioTech Sidebar
-> Restart Firefox
-> Check the Error Console
--> JS Error

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml ::  :: line 644"  data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 650

Does not happen without this Extension

Comment 1

10 years ago
Author has been contacted.

Comment 2

10 years ago
I am unable to test this bug currently, as I do not own or have access to a Mac system. Is there anyone else who can confirm this and/or give more details so I can try and find out what is wrong here? Thanks!
Kevin, so it doesn't occur on Windows?

Comment 4

10 years ago
I have not tested the latest version on Windows, but the system I've developed it on, Ubuntu, has worked fine. I have a Windows system around I will test it on and will make changes for things that may not work. Did it work until the update?(around the time right before FF3 got released) I changed a line or two because something broke in Firefox 3.0. I'm planning on making a few changes and add/remove some features in the future when I get some time to work on it.

Comment 5

10 years ago
Just tested (and updated the extension maxversion # too past the FF3 beta to FF3 Final) and found no problems on my Windows XP system.
Kevin, the error also appears on Window XP for me by using Biotech extension 1.1 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2pre) Gecko/2008070905 GranParadiso/3.0.2pre ID:2008070905

I believe you don't have enabled javascript.options.showInConsole and javascript.options.strict. You have to do that to see this entry. At least you need two restarts. One after the installation and one more after you have opened the sidebar. On the next start the error should appear in the Error Console.
OS: Mac OS X → All
Hardware: PC → All

Comment 7

10 years ago
Thanks for the lead, I will look into it shortly, then.

Comment 8

10 years ago
I can confirm the error on my XP machine with strict on. The error does not seem to hinder the working of the extension, which is good or else it would be more critical. I can not figure out why that line of code, which is not even in the code I wrote for the extension, is giving an error about giving an error. I will try to rewrite some parts in the near future and hope that will make the bug go away, but until then, I am not sure what I could do to fix the error. If anyone else is watching this and might know more about Firefox's internal code structure, I'd like a comment. I will post if I find more about this.

Comment 9

10 years ago
I can confirm with a different extension (https://addons.mozilla.org/en-US/firefox/addon/7598) on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Comment 10

10 years ago
What's interesting is that this is triggered for me every time I open my sidebar. 

Comment 11

10 years ago
Whoever it seems to have gone away after I installed the Extension Developer's extension and turned on the debugging prefs. I can't reproduce it any more :(. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Comment 12

10 years ago
unless it becomes a problem then, I'll consider this one resolved.
(Reporter)

Comment 13

9 years ago
Closing as invalid, no firefox bug also per comment #12 fixed in the Add-on
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.