Remove |nsIAutoCompleteSession| usage from mailnews/addrbook

RESOLVED DUPLICATE of bug 370306

Status

MailNews Core
Address Book
RESOLVED DUPLICATE of bug 370306
10 years ago
10 years ago

People

(Reporter: Nick Kreeger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
In order to |--enable-mailnews| when building a XULRunner on the 1.9 branch, all usage of |nsIAutoCompleteSession| must be removed.
(Reporter)

Comment 1

10 years ago
Build output:

../../../dist/bin/xpidl -m header -w -I/home/nick/Projects/mailnews_xulrunner/mozilla/mailnews/addrbook/public -I../../../dist/idl -o _xpidlgen/nsIAbAutoCompleteSession /home/nick/Projects/mailnews_xulrunner/mozilla/mailnews/addrbook/public/nsIAbAutoCompleteSession.idl
/home/nick/Projects/mailnews_xulrunner/mozilla/mailnews/addrbook/public/nsIAbAutoCompleteSession.idl:39: can't open included file nsIAutoCompleteSession.idl for reading
(Reporter)

Updated

10 years ago
Depends on: 432162
Duping to bug 370306 which is actually what we really need to do here. We need to translate to fully use toolkit's autocomplete (which although some interfaces are named the same they are different) not just remove the usage of one interface.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370306
No longer depends on: 432162
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.