if start page is a file:// url, firefox shows go button instead of star

RESOLVED FIXED in Firefox 3.1a1

Status

()

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: wgianopoulos, Assigned: dao)

Tracking

({regression, verified1.9.0.2})

Trunk
Firefox 3.1a1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

IF your startpage is a file:// type url, Firefox shows the go button instead of the star in the addressbar.  This is a regression which did NOT occur in beta5.
Flags: blocking-firefox3?
This happens on Windows as well.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050406 Minefield/3.0pre ID:2008050406

OS -> All
OS: Linux → All
Hardware: PC → All
Component: Toolbars → Tabbed Browser
Keywords: qawanted
QA Contact: toolbars → tabbed.browser
This will not block the final release of Firefox 3. Any patch will need unit tests in order to be approved.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Not sure why this regressed now, a range would be helpful.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #319439 - Flags: review?(gavin.sharp)
Just tested the 2008-04-05-04 nightly, and this bug occurred only occasionally. Seems like delayedStartup and pageload are really racing. Maybe pageload got a little bit faster recently.
Keywords: qawanted, regression
Attachment #319439 - Attachment description: don't set pageproxystate="invalid" in delayedStart → don't set pageproxystate="invalid" in delayedStartup()
(In reply to comment #3)
> Created an attachment (id=319439) [details]
> don't set pageproxystate="invalid" in delayedStart
> 
> Not sure why this regressed now, a range would be helpful.
> 
Checkins during regression window:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-04-17+04%3A13&maxdate=2008-04-18+04%3A02&cvsroot=%2Fcvsroot
(In reply to comment #3)
> Created an attachment (id=319439) [details]
> don't set pageproxystate="invalid" in delayedStart

This fixes the issue for me.
(In reply to comment #2)
> This will not block the final release of Firefox 3. Any patch will need unit
> tests in order to be approved.
> 

This will be a more visible issue for builds included with linux distributions, which tend to come with start pages set to things like "file:///usr/share/doc/HTML/index.html"
Summary: if start page is a file:// url, firefox shows go button instaed of star → if start page is a file:// url, firefox shows go button instead of star
This was regressed by the check-in for bug 425814.
Blocks: 425814
Keywords: regression
Comment on attachment 319439 [details] [diff] [review]
don't set pageproxystate="invalid" in delayedStartup()

Blake moved this from browserStartup() to delayed startup in revision 1.107 of browser.js, with no indication of why :(

I don't think we need to take this for Firefox 3.
Attachment #319439 - Flags: review?(gavin.sharp) → review+
Flags: wanted1.9.0.x?
(In reply to comment #9)
> (From update of attachment 319439 [details] [diff] [review])
> Blake moved this from browserStartup() to delayed startup in revision 1.107 of
> browser.js, with no indication of why :(

It still seems to be done in Startup in navigator.js.
Whiteboard: [RC2?]
Attachment #319439 - Flags: approval1.9?
Whiteboard: [RC2?]
Attachment #319439 - Flags: approval1.9?
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/index.cgi/rev/5034371d2778
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1
Duplicate of this bug: 439875
Attachment #319439 - Flags: approval1.9.0.1?
Attachment #319439 - Flags: approval1.9.0.1? → approval1.9.0.2?
Target Milestone: Firefox 3.1 → Firefox 3.1a1
Comment on attachment 319439 [details] [diff] [review]
don't set pageproxystate="invalid" in delayedStartup()

Approved for 1.9.0.2. Please land in CVS. a=ss
Attachment #319439 - Flags: approval1.9.0.2? → approval1.9.0.2+
Keywords: checkin-needed
Flags: wanted1.9.0.x? → wanted1.9.0.x+
Whiteboard: [needs checkin on 1.9]
mozilla/browser/base/content/browser.js 	1.1037
mozilla/browser/base/content/browser.xul 	1.467 
Whiteboard: [needs checkin on 1.9]
Verified for 1.9.0.2 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2) Gecko/2008090212 Firefox/3.0.2.
You need to log in before you can comment on or make changes to this bug.