Status

P3
critical
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: marina, Assigned: bugzilla)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

19 years ago
**** observed with 2000-06-20-08 build ****
Steps to reproduce:
-from the brower window go File|Send page
//note : no Mail Composition window comes up (i am able to send a link though)

Comment 1

19 years ago
re-assigning.
Assignee: mscott → ducarroz
Component: Mail Back End → Composition

Comment 2

19 years ago
nominate nsbeta2:

This is a regression from beta 1.  The "Send Page" feature does not work at all.
Severity: normal → critical
Keywords: nsbeta2
(Assignee)

Comment 3

19 years ago
Something broken in the navigator JS:



JavaScript error: 

 line 0: SendPage is not defined



However, Send link still working. Should be easy to fix.

Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Reporter)

Comment 4

19 years ago
In today's build it is impossible to Send link either: i do get a composition 
window (as oppose to Send page case where i get none) but no link is insetred ( 
it was there yesterday...)
**** observed with 2000-06-21-08 build ****
(Assignee)

Comment 5

19 years ago
I have a fix for the Send page bustage:

Index: mailEditorOverlay.xul
===================================================================
RCS file: /cvsroot/mozilla/mailnews/base/resources/content/mailEditorOverlay.xul,v
retrieving revision 1.1
diff -r1.1 mailEditorOverlay.xul
29c29
<   	<broadcaster id="cmd_sendPage" value="&sendPage.label;" accesskey="&sendPage.accesskey;" oncommand=
"SendPage();"/>
---
>   	<broadcaster id="cmd_sendPage" value="&sendPage.label;" accesskey="&sendPage.accesskey;" oncommand="sendPage();"/>

Index: mailNavigatorOverlay.xul
===================================================================
RCS file: /cvsroot/mozilla/mailnews/base/resources/content/mailNavigatorOverlay.xul,v
retrieving revision 1.1
diff -r1.1 mailNavigatorOverlay.xul
37c37
<   	<broadcaster id="cmd_sendPage" value="&sendPage.label;" accesskey="&sendPage.accesskey;" oncommand=
"SendPage();"/>
---
>   	<broadcaster id="cmd_sendPage" value="&sendPage.label;" accesskey="&sendPage.accesskey;" oncommand=
"sendPage();"/>
Whiteboard: Fix in hand

Comment 6

19 years ago
Putting on [nsbeta2+] radar.
Whiteboard: Fix in hand → [nsbeta2+]Fix in hand
(Assignee)

Comment 7

19 years ago
fix reviewed by mscott.

Fixed and checked in. QA, if you still have problem with Send Link, please open 
a new bug. Thanks
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2+]Fix in hand → [nsbeta2+]
(Reporter)

Comment 8

19 years ago
it looks like Send a link is a random problem, i can not reproduce it right now, 
i do have a link inserted in the composition window.

Comment 9

19 years ago
Verifying fix...
QA Contact: lchiang → pratikd

Comment 10

19 years ago
pratik - if verified, pls mark "verified". Thanks.

Comment 11

19 years ago
Send Page from browser window opens up compose but the message window in compose 
is frozen. I don't see a link in the message window either nor can I type 
anything into it. Send doesn't work either. I am using 2000-06-26-08 M17 on NT4. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 12

19 years ago
hmm.... worked OK for me in today build 2000-06-26 on Win NT
(Assignee)

Comment 13

19 years ago
Works fine for me too.
pratik, are use unsing plain text or html compose message?

Anyway, If you still have your problem, please file another bug.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 14

19 years ago
Looks like my current profile was currupted. Marking as fixed. 
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
Using Build 2000-06-26 M17 on NT4, Linux and MAC
Verified: Fixed

Comment 16

19 years ago
*** Bug 45434 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.