If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't save prefs after going from Fonts panel to another

VERIFIED FIXED in M18

Status

SeaMonkey
Preferences
P1
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: jesup, Assigned: matt)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
prefs wouldn't save due to an error in pref-fonts.js line 177 - it didn't like
dataobject.

JavaScript error: 
chrome://communicator/content/pref/pref-fonts.js line 177: dataObject has no
properties
hi Randell, what build id did you see this problem with? and could you pls
provide the steps you took to encounter this bug? thx!

Comment 2

18 years ago
qawanted, need anyone with freeBSD.

Need clearer reproduction steps also...might just be the old "OK button doesn't 
work" problem.
Keywords: qawanted
(Reporter)

Comment 3

18 years ago
To repeat:
Menu Edit->Preferences
Click on Appearance
Click on Fonts
Change anything elsewhere in prefs (I changed Advanced -> Javascript in
Mail/news)
Select OK.
 

Comment 4

18 years ago
Thanks for the clearer steps; I'm now able to determine that this is a dup of 
bug 36504, per my comment near the end of that bug.  This really happens after 
you go to the Fonts category and then just switch to any other category (you 
don't have to change another pref as you mentioned)...thus, it's 36504.

*** This bug has been marked as a duplicate of 36504 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
actually, reopening.  see my comments in bug 36504 for explanation
Status: RESOLVED → UNCONFIRMED
OS: FreeBSD → All
Hardware: PC → All
Resolution: DUPLICATE → ---

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Blocks: 40891
Randell, thx for the steps! in fact, it could be further simplified to:

1. open Preferences dialog.
2. select Fonts category.
3. go to any other category.
4. try to click OK to save and dismiss prefs.

result: cannot save and dismiss prefs. i've clarified the summary a bit. a very 
annoying regression, indeed --nominating for beta2.
URL: none
Keywords: qawanted → nsbeta2, regression
Summary: Can't save prefs due to problem with fonts → Can't save prefs after going from Fonts panel to another

Comment 7

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 8

18 years ago
Matt, is this our bug?
Priority: P3 → P1
Target Milestone: --- → M18
bumping up sev. being unable to save prefs is bad.
Severity: normal → major
*** Bug 43845 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
*** Bug 44411 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
*** Bug 44674 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

17 years ago
*** Bug 37897 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

17 years ago
This looks like it is a pretty old bug that never got dupped.
http://bugzilla.mozilla.org/show_bug.cgi?id=37897
is the dup of this bug and was first noticed 5/02/00

I'm not really sure if this ever worked actually.
What I can see is happening is that saveFontPrefs()
gets set when you open the fonts pane.  
Then 
parent.hPrefWindow.wsm.dataManager.pageData["chrome://pref/content/pref-fonts.xu
l"] = GetFields();

should get set.
Then you switch to another pane and 
hit ok and saveFontPrefs() gets called but 
parent.hPrefWindow.wsm.dataManager.pageData["chrome://pref/content/pref-fonts.xu
l"] looks the object.
Thus we get this error.
Status: NEW → ASSIGNED

Comment 15

17 years ago
Is this only a problem for the Fonts preference?  Answer seems to be yes.

Do we have a fix waiting to be checking in or 90% done.  Answer seems to be no.

With those answers, I think would we be willing to ship beta2 if the fonts prefs
did not working. I'm thinking we could release note it and ship it, so yes we
might ship beta2 with this bug.

Matt, can you answer those 2 questions?  IF the answers are what I suspect, I
will recommend that we release note it and fix it for beta3 - aka remove the
nsbeta2+.
(Assignee)

Comment 16

17 years ago
>Is this only a problem for the Fonts preference?  
>Answer seems to be yes.
You are correct my friend.

>Do we have a fix waiting to be checking in or 90% done.  Answer seems to be no.
We have a fix in hand waiting for the tree to be nice and green.

For you John...I will kill this bug tomorrow.
(Assignee)

Comment 17

17 years ago
changing chrome url for this url to get stored.
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

17 years ago
*** Bug 45434 has been marked as a duplicate of this bug. ***
vrfy fixed using comm bits 2000.07.17.08 on winnt and linux. unable to test with
mac commercialor mozilla bits, as they crash on startup
(http://bugscape.mcom.com/show_bug.cgi?id=1465 for comm bits).
Status: RESOLVED → VERIFIED
hokay, i worked around my crasher on the mac, and was able to vrfy this using
today's moz bits...
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.