Emphasize reason for logging in to install add-on

VERIFIED FIXED in 3.4.3

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: wenzel, Assigned: Chris Pollett)

Tracking

unspecified
3.4.3

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

10 years ago
Ever so often, I come across user feedback that suggests "login is required in order to download add-ons", which is not correct for public add-ons, just for untested, experimental add-ons.

I think we need to emphasize the reason why logging in is required for these.

At the very least, the disabled install button should show something like "This add-on is experimental" over the button, followed by the current "Log in to install this add-on" underneath. Possibly linking from the word "experimental" to some explanation what that means for add-ons.

Suggesting for resolution in 3.4.3 due to the confusion that's apparently caused at the moment, and CCing Madhava and Basil for comment. Everyone else, feel free to speak up too :)
I'm not really clear on the reason for logging in myself, as we still don't have any text or agreement that explains about how the add-ons aren't reviewed and might do bad things, etc. So it seems like logging in is just an uninformative hurdle that users are forced to go through.

Since the sandbox concept was invented, I've always thought at some point we would have a page that explains what the sandbox is and how the add-ons can be dangerous, and at the bottom would be a button that says "Yes, enable the sandbox" or "No, only show me reviewed add-ons". That flag turned into a checkbox hidden in the user's account with no description, which turned into everyone sees sandbox add-ons and all logged-in users can install them.

So, as it is currently, I don't think logging in is helping anything at all - we should either get rid of it or add some information to make it useful. I guess this bug is a step towards the latter, but I'm not clear on where we would put this so that everyone sees it without bringing back the account flag.
We could show a <div> with information when the "show experimental add-ons" is checked (or when the "log in" link is clicked in an install add-on box).  I'm thinking of a popup style similar to adding a friend in facebook.

Keeping the wording succinct would be a challenge.

Updated

10 years ago
Assignee: nobody → cpollett

Comment 3

10 years ago
Here's what I suggest we need to do

1. When not logged in, change the button text from "_Log in_ to install this add-on" to "You must _Log in_ to install this _experimental_ add-on"

_Log in_ would link to the login page as it did before
_experimental_ would like to a new experimental add-ons information page

2. We should make the upper left hand text "experimental" on the landing, listings & details pages link to the new experimental add-ons info page.


Here is the contents of that new page...styled similarly to https://addons.mozilla.org/firefox/pages/sandbox

HTML Page Title: Experimental Add-ons
Page Header: Experimental Add-ons


What is an experimental add-on?

Experimental add-ons are meant for advanced users to test add-ons before they are made available and reviewed for general use. Many add-ons may be in prototype form. Experimental add-ons may be alpha, beta or pre-production in quality, performance and features.

Caution should be used when installing experimental add-ons, as they have not been tested by an editor and may harm your computer configuration.


How do I know an experimental add-on when I see one on the site?

Experimental add-ons are marked with an "experimental" label and require login before you install them.


Why do I have to login to install an experimental add-on?

The add-on site requires that users login to install experimental add-ons as a  reminder that you are about to undertake a risk step.


Do I have to login or need an account to install a public add-on?

No. The add-on site does not require you to have a user account or to login in order to install a public add-on.

[Link back to previous page]
(In reply to comment #3)
> Here's what I suggest we need to do
> 
> 1. When not logged in, change the button text from "_Log in_ to install this
> add-on" to "You must _Log in_ to install this _experimental_ add-on"
> 
> _Log in_ would link to the login page as it did before
> _experimental_ would like to a new experimental add-ons information page
> 

Since we're putting this text on a button we should be very deliberate with our links.  I think someone may click on "experimental" thinking it's just part of the button.  I'd suggest using your text but then adding "Why?" in a different color afterward which goes to the explanatory link.  A click anywhere else in the button should pop up a log in box (or go to the log in page if we don't have time for a pop up.)
(Assignee)

Comment 5

10 years ago
Created attachment 323482 [details] [diff] [review]
patch to add text
Attachment #323482 - Flags: review?(clouserw)
(Assignee)

Comment 6

10 years ago
This patch adds Baz's text. The only slight quirk with it is that because of the way the pages controller works, it is hard to get the title exactly as specified (title comes url), so I tried my best.

Comment 7

10 years ago
Comment on attachment 323482 [details] [diff] [review]
patch to add text

In addition to 40 billion comment updates, it looks like you've also accidentally added some unrelated strings in this patch.
Comment on attachment 323482 [details] [diff] [review]
patch to add text

This has the admin strings at the top of the .po that shouldn't be added as well as some review_* strings that don't appear to be in this patch.

Also you're using the HTTP_REFERER header in the page which is not available on the other side of the netscaler.  If you want a dynamic link there you'll have to use JS.
Attachment #323482 - Flags: review?(clouserw) → review-
(Assignee)

Comment 9

10 years ago
Created attachment 323509 [details] [diff] [review]
new patch fixing both problems of last patch
Attachment #323482 - Attachment is obsolete: true
Attachment #323509 - Flags: review?(clouserw)
(Assignee)

Comment 10

10 years ago
Created attachment 323510 [details] [diff] [review]
patch with improved js
Attachment #323509 - Attachment is obsolete: true
Attachment #323510 - Flags: review?(clouserw)
Attachment #323509 - Flags: review?(clouserw)
(Assignee)

Comment 11

10 years ago
Created attachment 323520 [details] [diff] [review]
removed extra review_flag strings and localized back to previous page
Attachment #323510 - Attachment is obsolete: true
Attachment #323520 - Flags: review?(clouserw)
Attachment #323510 - Flags: review?(clouserw)
Comment on attachment 323520 [details] [diff] [review]
removed extra review_flag strings and localized back to previous page

What you have is good, but there is no localized experiemental_addons page so it just comes up blank.  If you want to attach that page in addition to this page, I'll r+
(Assignee)

Comment 13

10 years ago
Created attachment 323577 [details] [diff] [review]
missing file
Attachment #323577 - Flags: review?(clouserw)

Updated

10 years ago
Attachment #323520 - Flags: review?(clouserw) → review+

Updated

10 years ago
Attachment #323577 - Flags: review?(clouserw) → review+
(Assignee)

Comment 14

10 years ago
checked into r14567
Keywords: push-needed
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified FIXED on https://preview.addons.mozilla.org/en-US/firefox/pages/experimentalAddons.

I noticed some uber grammatical nits (in specific cases, "login" the noun should be "log in" the intransitive verb) but I'll spin that off, since I think we're pretty much string-frozen at this point.
Status: RESOLVED → VERIFIED
Keywords: push-needed
Duplicate of this bug: 440282
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.