on every download firefox freezes until download is complete

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: andre.mueller, Unassigned)

Tracking

1.8 Branch
PowerPC
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Since firefox 2.0.0.8 or later, I do not remember the correct version, when the problem occurred first, every download to desktop or selected destination freezes firefox fully for the first 20-30 seconds or until the file to be downloaded has been downloaded completely. Also CPU load raises in this freeze status. Before this problem was introduced, parallel downloads were possible and no temporary freeze occurred. We have this problems on all of our Macs (PPC - no idea on Intel-CPU).

Reproducible: Always

Steps to Reproduce:
1. klick on any link with a file to downloades (small, large etc.)
2. 
3.
Actual Results:  
small files tend to freeze firefox until their complete download, where large files tend to freeze firefox only the first 20-30 seconds the begin to download an to be visible in the progress-bar in the download-manager.


same seems to be true in actual version of Thunderbird, but there the problem is less obvious
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

11 years ago
It seems that the problem arises if the download list has become very long over time. By clearing the download list the problem disappears.
Good news is that this has been fixed in Firefox 3!  Resolving as WORKSFORME per comment 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.