Favourite Folders should show in other views too (or at least it should be possible to configure TB that way)

NEW
Unassigned

Status

--
enhancement
10 years ago
5 months ago

People

(Reporter: samul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: version 2.0.0.14 (20080421)

Currently, I can switch folder views between: all, unread, recent, favourite.

While this is an excellent feature, usability isn't IMHO as good as it could be.

#1
It should be possible to mix views or to define sticky folders that show up in any view (or make the favourite folders show up in any view).

#2
To my knowledge there are no keyboard shortcuts to switch between views. Such shortcuts should be defined. If there are such shortcuts, they should IMHO be listed in the menu.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
1. does this aim favorites+unread especially, cause that is also in bug 426824, or more than that? Or the intention is just to *see* (special color, underline, icon or else..)that a folder is favorite when in all or another view? 
[ Cause latter should be achievable if a selector is present for favorite in css, which I was unable to find ..] 

2. dunno, may ask in news groups or forums ..
Component: General → Mail Window Front End
OS: Windows XP → All
QA Contact: general → front-end
Hardware: PC → All

Comment 2

10 years ago
No there are no shortcuts for the folder views.

IIRC I saw some extension which added a small area with the Favorite/Unread etc folder views above the accounts. Unfortunately I don't recall what it was named:(

Something we should do though, IMO.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

10 years ago
(In reply to comment #2)
> IIRC I saw some extension which added a small area with the Favorite/Unread etc
> folder views above the accounts.
 Additional Folder Views
https://addons.mozilla.org/en-US/thunderbird/addon/4222
gives a "second" folderpane that can have different views. Well, not merged ..

1.For one thing, I was looking for a css selector to just highlight those favorite between others and could't find one. well, just for ui rather ..
2.For this "combined view" the header/sorter with total/unread may just do if it was a Sorter (view Favorites, sorting Unread ..)
3.Or may just add favorites to that one ..


(Reporter)

Comment 4

10 years ago
(In reply to comment #1)
> 1. does this aim favorites+unread especially, cause that is also in bug 426824,
> or more than that?

I think it's essentially the same thing (I did a search but didn't find that other RFE). I was thinking of something more general that would subsume a combined fav+unread view.

> Additional Folder Views
https://addons.mozilla.org/en-US/thunderbird/addon/4222
gives a "second" folderpane that can have different views

Cool. I didn't know that one. I'm not 100% happy with the split view but it solves the problem. Thanks for the hint.

Comment 5

10 years ago
Is that some sort of "Works For Me" ? meaning that it works today and the improvement could stay in extensions. I'll see also the bug 426824 for opinion.

Would this remain then only for the point 2. (key shorts for view) ? In that case the description (title) could change ..
(Reporter)

Comment 6

10 years ago
> Is that some sort of "Works For Me" ?

I wouldn't have posted a RFE if I had known about this extension and in this respect: yes, it works for "me". I don't think this split view is "beautiful" though.

> Would this remain then only for the point 2. (key shorts for view) ?

With the split/combined view this isn't so much of a problem because one hardly ever have to switch between folder views.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 7

10 years ago
Reopening as i think it's still a good RFE. (The extension is just a workaround.)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

10 years ago
Status: REOPENED → NEW
(Reporter)

Comment 8

10 years ago
Yes, after some time with the extension I have to say it's not really a solution.  Certain keyboard shortcuts don't work properly. 3rd party extensions get easily confused by this.

Updated

4 years ago
See Also: → bug 426824

Comment 9

5 months ago
The extension Additional Folder Views (https://addons.mozilla.org/en-US/thunderbird/addon/additional-folder-views/) is now dead ("Works with Thunderbird 2.0a1 - 3.0a1").

I wish we could have a "Folder View" feature (http://www.hacking-guide.com/wp-content/uploads/2016/10/hit-view.png) able to merge several of its options. For my own case, by example, I want to always see my "Favorite" and "Unread" folders.

Instead of having to choose between "Unread", "Favorite" and "Recent", it would be helpful to be able to select one or more of them.
You need to log in before you can comment on or make changes to this bug.